aboutsummaryrefslogtreecommitdiff
path: root/www/mod_backtrace
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-11 05:08:18 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-11 05:08:18 +0000
commit0574d1cb27bf4f1f8ae9cc51b3cdf399ca644ae2 (patch)
tree1cf27e585181bba125432f07a69c67beefe030eb /www/mod_backtrace
parent834b807156418a8afc91673d6620bf3fa652ddd5 (diff)
downloadports-0574d1cb27bf4f1f8ae9cc51b3cdf399ca644ae2.tar.gz
ports-0574d1cb27bf4f1f8ae9cc51b3cdf399ca644ae2.zip
Notes
Diffstat (limited to 'www/mod_backtrace')
-rw-r--r--www/mod_backtrace/Makefile43
-rw-r--r--www/mod_backtrace/distinfo2
-rw-r--r--www/mod_backtrace/pkg-descr24
3 files changed, 69 insertions, 0 deletions
diff --git a/www/mod_backtrace/Makefile b/www/mod_backtrace/Makefile
new file mode 100644
index 000000000000..21ec22083131
--- /dev/null
+++ b/www/mod_backtrace/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: mod_backtrace
+# Date created: Thu Nov 4 10:08:27 CET 2010
+# Whom: Frank Wall <fw@moov.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_backtrace
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://people.apache.org/~trawick/ \
+ http://dl.moov.de/freebsd/${PORTNAME}/
+DISTNAME= ${PORTNAME}.c
+EXTRACT_SUFX= # none
+EXTRACT_ONLY= # empty
+
+MAINTAINER= fw@moov.de
+COMMENT= Collects backtraces when a child process crashes
+
+LIB_DEPENDS= execinfo.1:${PORTSDIR}/devel/libexecinfo
+
+MAKE_JOBS_SAFE= yes
+
+USE_APACHE= 20+
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+AP_EXTRAS+= -lexecinfo
+AP_LIB+= ${LOCALBASE}/lib
+SHORTMODNAME= backtrace
+
+WRKSRC= ${WRKDIR}
+
+pre-everything::
+ @${ECHO_MSG} "*********************** PLEASE NOTE! ***********************"
+ @${ECHO_MSG} "Apache httpd must be built with the --enable-exception-hook"
+ @${ECHO_MSG} "configure option and mod_so enabled."
+ @${ECHO_MSG} "*********************** PLEASE NOTE! ***********************"
+
+do-extract:
+ ${MKDIR} ${WRKSRC}/
+ ${CP} ${DISTDIR}/${PORTNAME}.c ${WRKSRC}/
+
+.include <bsd.port.mk>
diff --git a/www/mod_backtrace/distinfo b/www/mod_backtrace/distinfo
new file mode 100644
index 000000000000..a2529715478a
--- /dev/null
+++ b/www/mod_backtrace/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mod_backtrace.c) = 56fd08206e5b5a2b6258dc2b48e0466010640ddac12dcc153e65c455f294e900
+SIZE (mod_backtrace.c) = 5965
diff --git a/www/mod_backtrace/pkg-descr b/www/mod_backtrace/pkg-descr
new file mode 100644
index 000000000000..89d090bde31b
--- /dev/null
+++ b/www/mod_backtrace/pkg-descr
@@ -0,0 +1,24 @@
+mod_backtrace is an experimental module for Apache httpd 2.x which
+collects backtraces when a child process crashes. Currently it is
+implemented only on Linux and FreeBSD, but other platforms could be
+supported in the future.
+
+Requirements: Apache httpd >= 2.0.49 must be built with the
+--enable-exception-hook configure option and mod_so enabled.
+
+Activating mod_backtrace:
+
+ 1. Load it like any other DSO:
+ LoadModule backtrace_module modules/mod_backtrace.so
+
+ 2. Enable exception hooks for modules like mod_backtrace:
+ EnableExceptionHook On
+
+ 3. Choose where backtrace information should be written.
+ If you want backtraces from crashes to be reported some place other
+ than the error log, use the BacktraceLog directive to specify a
+ fully-qualified filename for the log to which backtraces will be
+ written. Note that the web server user id (e.g., "nobody") must
+ be able to create or append to this log file, as the log file is
+
+WWW: http://people.apache.org/~trawick/exception_hook.html