aboutsummaryrefslogtreecommitdiff
path: root/www/mod_bandwidth
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2003-07-03 15:13:09 +0000
committerErwin Lansing <erwin@FreeBSD.org>2003-07-03 15:13:09 +0000
commit26390dc1ff8888e5a7b3851faa1b153b0fb9a0ff (patch)
tree359ce9fca8a40bc406b7b2e232cb514427314531 /www/mod_bandwidth
parentc692255708f20aa7d54cd0a89f3b645b1d1ab17a (diff)
downloadports-26390dc1ff8888e5a7b3851faa1b153b0fb9a0ff.tar.gz
ports-26390dc1ff8888e5a7b3851faa1b153b0fb9a0ff.zip
Notes
Diffstat (limited to 'www/mod_bandwidth')
-rw-r--r--www/mod_bandwidth/Makefile35
-rw-r--r--www/mod_bandwidth/distinfo1
-rw-r--r--www/mod_bandwidth/pkg-descr7
-rw-r--r--www/mod_bandwidth/pkg-message5
-rw-r--r--www/mod_bandwidth/pkg-plist3
5 files changed, 51 insertions, 0 deletions
diff --git a/www/mod_bandwidth/Makefile b/www/mod_bandwidth/Makefile
new file mode 100644
index 000000000000..35e021880316
--- /dev/null
+++ b/www/mod_bandwidth/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mod_bandwidth
+# Date created: 2 July 2003
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_bandwidth
+PORTVERSION= 2.0.4
+CATEGORIES= www
+MASTER_SITES= http://www.cultdeadsheep.org/FreeBSD/ports/download/distfiles/
+EXTRACT_SUFX= .c
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Bandwidth management module for the Apache webserver
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+NO_WRKSUBDIR= YES
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PORTNAME}.c
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.so)
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_bandwidth/distinfo b/www/mod_bandwidth/distinfo
new file mode 100644
index 000000000000..734aa1e4243e
--- /dev/null
+++ b/www/mod_bandwidth/distinfo
@@ -0,0 +1 @@
+MD5 (mod_bandwidth-2.0.4.c) = 00f0905d777f79485beb428b53191ecf
diff --git a/www/mod_bandwidth/pkg-descr b/www/mod_bandwidth/pkg-descr
new file mode 100644
index 000000000000..e97f874bbba7
--- /dev/null
+++ b/www/mod_bandwidth/pkg-descr
@@ -0,0 +1,7 @@
+Bandwidth management module for the Apache webserver.
+mod_bandwidth is a module for the Apache webserver that
+enable the setting of server-wide or per connection
+bandwidth limits, based on the directory, size of files
+and remote IP/domain.
+
+WWW: http://www.cohprog.com/mod_bandwidth.html
diff --git a/www/mod_bandwidth/pkg-message b/www/mod_bandwidth/pkg-message
new file mode 100644
index 000000000000..4666b58deaf5
--- /dev/null
+++ b/www/mod_bandwidth/pkg-message
@@ -0,0 +1,5 @@
+************************************************************
+To configure correctly mod_bandwidth you can find directives
+documentation here :
+http://www.cohprog.com/v3/bandwidth/doc-en.html
+************************************************************
diff --git a/www/mod_bandwidth/pkg-plist b/www/mod_bandwidth/pkg-plist
new file mode 100644
index 000000000000..82149cd49e09
--- /dev/null
+++ b/www/mod_bandwidth/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_bandwidth.so
+@exec %D/sbin/apxs -e -A -n mod_bandwidth %D/%F
+@unexec echo "===> If you do not plan on reinstalling mod_bandwidth, you must manually remove"; echo "===> references to it in httpd.conf."