aboutsummaryrefslogtreecommitdiff
path: root/www/mod_cgi_debug
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-10 22:48:46 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-10 22:48:46 +0000
commit6f8fbc6735725c311a366de1469b64db7078367d (patch)
tree3f677dd8612b7d58fe87da10cbfc286e356883a1 /www/mod_cgi_debug
parent62752967766b827b86924f706413443927363637 (diff)
downloadports-6f8fbc6735725c311a366de1469b64db7078367d.tar.gz
ports-6f8fbc6735725c311a366de1469b64db7078367d.zip
Notes
Diffstat (limited to 'www/mod_cgi_debug')
-rw-r--r--www/mod_cgi_debug/Makefile26
-rw-r--r--www/mod_cgi_debug/distinfo1
-rw-r--r--www/mod_cgi_debug/pkg-comment1
-rw-r--r--www/mod_cgi_debug/pkg-descr14
-rw-r--r--www/mod_cgi_debug/pkg-plist3
5 files changed, 45 insertions, 0 deletions
diff --git a/www/mod_cgi_debug/Makefile b/www/mod_cgi_debug/Makefile
new file mode 100644
index 000000000000..81741b3bbfe3
--- /dev/null
+++ b/www/mod_cgi_debug/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: mod_cgi_debug
+# Date created: 10 April 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_cgi_debug
+PORTVERSION= 0.7
+CATEGORIES= www
+MASTER_SITES= http://www.tangent.org/mod_cgi_debug/
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ ${APXS} -i -A -n ${PORTNAME:S/_//g} ${WRKSRC}/${PORTNAME}.so
+
+.include <bsd.port.mk>
diff --git a/www/mod_cgi_debug/distinfo b/www/mod_cgi_debug/distinfo
new file mode 100644
index 000000000000..2de42be1fd31
--- /dev/null
+++ b/www/mod_cgi_debug/distinfo
@@ -0,0 +1 @@
+MD5 (mod_cgi_debug-0.7.tar.gz) = c355a28002e876234eee48802d18f246
diff --git a/www/mod_cgi_debug/pkg-comment b/www/mod_cgi_debug/pkg-comment
new file mode 100644
index 000000000000..93fa51fd53d2
--- /dev/null
+++ b/www/mod_cgi_debug/pkg-comment
@@ -0,0 +1 @@
+Apache module to make debugging server-side scripts easier
diff --git a/www/mod_cgi_debug/pkg-descr b/www/mod_cgi_debug/pkg-descr
new file mode 100644
index 000000000000..0f2a3eedd4ac
--- /dev/null
+++ b/www/mod_cgi_debug/pkg-descr
@@ -0,0 +1,14 @@
+The idea is that we all write CGI and just about every CGI
+writer or Java Servlet writer, or PHP... or even ModPerl..
+or...) ends up printing certain standard pieces of info to
+the screen to see just what sort of data that they are receiving.
+So... we write a loop and print out our variables.
+
+Either have ModCGIDebug tack on the info to your CGI while it
+is running or use the handy dandy .env virtual page to see all
+that there is to seeor at least what we have found the need to
+print out so far).
+
+Some assembly required, batteries not included.
+
+WWW: http://www.tangent.org/mod_cgi_debug/
diff --git a/www/mod_cgi_debug/pkg-plist b/www/mod_cgi_debug/pkg-plist
new file mode 100644
index 000000000000..c598eef2ba8c
--- /dev/null
+++ b/www/mod_cgi_debug/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_cgi_debug.so
+@exec %D/sbin/apxs -e -A -n cgi_debug %D/%F
+@unexec %D/sbin/apxs -e -A -n cgi_debug %D/%F