aboutsummaryrefslogtreecommitdiff
path: root/www/mod_clamav/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-08-15 06:53:14 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-08-15 06:53:14 +0000
commit6bcb94a52c3df27eb0f21d7411c617737e074070 (patch)
treee716746b732e0b1596acf675dcc8825a95234f02 /www/mod_clamav/Makefile
parent32686dd1978e187ea365538e941d03aa3adbeff9 (diff)
downloadports-6bcb94a52c3df27eb0f21d7411c617737e074070.tar.gz
ports-6bcb94a52c3df27eb0f21d7411c617737e074070.zip
Notes
Diffstat (limited to 'www/mod_clamav/Makefile')
-rw-r--r--www/mod_clamav/Makefile25
1 files changed, 16 insertions, 9 deletions
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index c5d5313dc727..ff962b3e0cbd 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -6,27 +6,35 @@
#
PORTNAME= mod_clamav
-PORTVERSION= 0.21
-PORTREVISION= 3
+PORTVERSION= 0.22
+PORTREVISION= 1
CATEGORIES= www security
-MASTER_SITES= http://software.othello.ch/mod_clamav/
+MASTER_SITES= http://software.othello.ch/mod_clamav/ \
+ http://www.kommunity.net/download/mod_clamav/
MAINTAINER= tmueko@kommunity.net
-COMMENT= Scans content delivered by the Apache2 proxy module for viruses
-
-LIB_DEPENDS+= clamav.4:${PORTSDIR}/${CLAMAV_PORT}
+COMMENT= Scans content delivered by the Apache20 proxy module for viruses
USE_AUTOTOOLS= libtool:15
USE_APACHE= YES
WITH_APACHE2= YES
GNU_CONFIGURE= yes
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/include/apache22/http_core.h) || exists(${LOCALBASE}/include/apache/http_core.h)
+IGNORE= mod_clamav only compile and run with apache-2.0.x
+.endif
+
.if defined(WITH_CLAMAVDEVEL)
-CLAMAV_PORT= security/clamav-devel
+LIB_DEPENDS+= clamav:${PORTSDIR}/security/clamav-devel
.else
CLAMAV_PORT= security/clamav
+LIB_DEPENDS+= clamav:${PORTSDIR}/security/clamav
.endif
+BUILD_DEPENDS+= apache20:${PORTSDIR}/www/apache20
+
CONFIGURE_ARGS= --with-apxs=${PREFIX}/sbin/apxs \
--libdir=${PREFIX}/lib/apache2
CFLAGS+= -I${LOCALBASE}/include
@@ -39,5 +47,4 @@ CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" \
post-install:
@${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>