aboutsummaryrefslogtreecommitdiff
path: root/www/mod_cplusplus
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-02-03 09:18:37 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-02-03 09:18:37 +0000
commit5da5f6a01776a857626fc3288529abe430c66072 (patch)
tree75fdd0d17471b32326d7dd010a755e7ab2782e1d /www/mod_cplusplus
parentdd2480c3c3b3fbe2c95d1333364ccddcde14cccb (diff)
Notes
Diffstat (limited to 'www/mod_cplusplus')
-rw-r--r--www/mod_cplusplus/Makefile22
-rw-r--r--www/mod_cplusplus/distinfo6
-rw-r--r--www/mod_cplusplus/files/patch-configure.in46
-rw-r--r--www/mod_cplusplus/files/patch-example__handler__test_handler.cpp11
4 files changed, 13 insertions, 72 deletions
diff --git a/www/mod_cplusplus/Makefile b/www/mod_cplusplus/Makefile
index ec1d45d6b179..c695ec0a3a00 100644
--- a/www/mod_cplusplus/Makefile
+++ b/www/mod_cplusplus/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mod_cplusplus
-PORTVERSION= 1.5.3
-PORTREVISION= 1
+PORTVERSION= 1.5.4
CATEGORIES= www
MASTER_SITES= SF
MASTER_SITE_SUBDIR= modcplusplus
@@ -17,23 +16,22 @@ COMMENT= Apache module for loading C++ objects as handlers
USE_APACHE= 2.0+
USE_AUTOTOOLS= autoconf:262 autoheader:262 libtool:15 automake:19 aclocal:19
-ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
-AUTOMAKE_ARGS+= -a
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-apxs=${APXS}
+ACLOCAL_ARGS+= -I ${LOCALBASE}/share/aclocal
+AUTOMAKE_ARGS+= -a
SUB_FILES= pkg-message
SUB_LIST= "APACHEMODDIR=${APACHEMODDIR}"
-# Redefine the autotools run order to match what would happen in the
-# autogen.sh script. We cannot use that script directly since it does
-# not use the versioned autotools.
-run-autotools: run-autotools-aclocal patch-autotools run-autotools-autoheader \
- run-libtoolize run-autotools-automake run-autotools-autoconf
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-extract:
+ ${REINPLACE_CMD} -e 's,-Werror,,' ${WRKSRC}/configure.in
-run-libtoolize:
- @(cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} \
- ${LIBTOOLIZE} --force --copy)
+pre-configure:
+ (cd ${CONFIGURE_WRKSRC} && ${SETENV} ${AUTOTOOLS_ENV} ${LIBTOOLIZE} --force --copy)
do-install:
${INSTALL_DATA} ${WRKSRC}/include/*.h ${PREFIX}/${APACHEINCLUDEDIR}
diff --git a/www/mod_cplusplus/distinfo b/www/mod_cplusplus/distinfo
index 20c4b041fe50..ab69f1b3119d 100644
--- a/www/mod_cplusplus/distinfo
+++ b/www/mod_cplusplus/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_cplusplus-1.5.3.tar.gz) = 98fc77f010c76835a3930f24349d6c37
-SHA256 (mod_cplusplus-1.5.3.tar.gz) = 540720e86fdc7449375d18bce5cb4cea118a70f5d5df9ba2cd8eb615a85b116f
-SIZE (mod_cplusplus-1.5.3.tar.gz) = 125601
+MD5 (mod_cplusplus-1.5.4.tar.gz) = 6b6883d3c6149a2984cebfe5e3de7a02
+SHA256 (mod_cplusplus-1.5.4.tar.gz) = 606d167bd1a3b1613fa03c189478d457147db18bfecfe44512b0795bf687256a
+SIZE (mod_cplusplus-1.5.4.tar.gz) = 264205
diff --git a/www/mod_cplusplus/files/patch-configure.in b/www/mod_cplusplus/files/patch-configure.in
deleted file mode 100644
index 30a730368b35..000000000000
--- a/www/mod_cplusplus/files/patch-configure.in
+++ /dev/null
@@ -1,46 +0,0 @@
-*** configure.in.orig Sat Dec 30 10:47:15 2006
---- configure.in Sat Dec 30 10:56:16 2006
-***************
-*** 9,15 ****
- dnl hack to get shlib extension
- AC_MSG_CHECKING(what the shared library extension is)
- eval SHLIB_EXT=\"$shrext\"
-! if test "$SHLIB_EXT" == "" ; then
- AC_MSG_RESULT(could not determine shared library extension. Defaulting to .so)
- SHLIB_EXT=".so"
- fi
---- 9,15 ----
- dnl hack to get shlib extension
- AC_MSG_CHECKING(what the shared library extension is)
- eval SHLIB_EXT=\"$shrext\"
-! if test "x$SHLIB_EXT" = "x" ; then
- AC_MSG_RESULT(could not determine shared library extension. Defaulting to .so)
- SHLIB_EXT=".so"
- fi
-***************
-*** 58,69 ****
- fi
- ],)
-
-! if test "$INCLUDES" == "" ; then
- AC_MSG_ERROR(could not generate includes with apxs set to "$APXS" - you must specify a valid path to apxs using the --with-apxs flag)
- fi
-
- AC_CHECK_LIB(stdc++, __gxx_personality_v0, LIB_STDCPP="-lstdc++")
-! if test "$LIB_STDCPP" == "" ; then
- CPPFLAGS="$CPPFLAGS -DNO_STDCPP"
- fi
- CPLUSPLUS_BUILDDIR=`pwd`
---- 58,69 ----
- fi
- ],)
-
-! if test "x$INCLUDES" = "x" ; then
- AC_MSG_ERROR(could not generate includes with apxs set to "$APXS" - you must specify a valid path to apxs using the --with-apxs flag)
- fi
-
- AC_CHECK_LIB(stdc++, __gxx_personality_v0, LIB_STDCPP="-lstdc++")
-! if test "x$LIB_STDCPP" = "x" ; then
- CPPFLAGS="$CPPFLAGS -DNO_STDCPP"
- fi
- CPLUSPLUS_BUILDDIR=`pwd`
diff --git a/www/mod_cplusplus/files/patch-example__handler__test_handler.cpp b/www/mod_cplusplus/files/patch-example__handler__test_handler.cpp
deleted file mode 100644
index f91a76231d2b..000000000000
--- a/www/mod_cplusplus/files/patch-example__handler__test_handler.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- example/handler/test_handler.cpp.orig Wed Jun 13 14:15:35 2007
-+++ example/handler/test_handler.cpp Wed Jun 13 14:26:38 2007
-@@ -18,7 +18,7 @@
- int TestHandler::handler(ApacheRequestRec *pRequest)
- {
- mHits++;
-- pRequest->content_type("application/x-httpd-cgi");
-+ pRequest->content_type((char *)"application/x-httpd-cgi");
- pRequest->dump();
- pRequest->rprintf("BOO");
- ap_setup_client_block(pRequest->get_request_rec(), REQUEST_CHUNKED_ERROR);