aboutsummaryrefslogtreecommitdiff
path: root/www/mod_dtcl/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-01-29 05:51:46 +0000
committerSteve Price <steve@FreeBSD.org>2000-01-29 05:51:46 +0000
commit2afc94ccbe99f9dfabdb754001e892aedee09e09 (patch)
treef43625391e6b2ac52acabbd711ba40632766ed77 /www/mod_dtcl/Makefile
parenteeaf4387c558290832a3fbccfa3d0852ee03a8b4 (diff)
Notes
Diffstat (limited to 'www/mod_dtcl/Makefile')
-rw-r--r--www/mod_dtcl/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/www/mod_dtcl/Makefile b/www/mod_dtcl/Makefile
new file mode 100644
index 000000000000..276f6ed1b8c4
--- /dev/null
+++ b/www/mod_dtcl/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: mod_dtcl
+# Version required: 0.6.4-2
+# Date created: January 9, 1999
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+DISTNAME= libapache-mod-dtcl_0.6.4-2
+PKGNAME= mod_dtcl-0.6.4.2
+CATEGORIES= www tcl82
+MASTER_SITES= http://master.debian.org/~davidw/mod_dtcl/
+
+MAINTAINER= mi@aldan.algebra.com
+
+BUILD_DEPENDS= ${PREFIX}/sbin/apxs:${PORTSDIR}/www/apache13
+LIB_DEPENDS= tcl82:${PORTSDIR}/lang/tcl82
+
+WRKSRC= ${WRKDIR}/mod_dtcl
+
+MAKEFILE= ${FILESDIR}/Makefile.bsd
+
+MAN1= testdtcl.1
+MANCOMPRESSED= no
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/libmod_dtcl.so.1* \
+ ${PREFIX}/libexec/apache/mod_dtcl.so
+ ${INSTALL_PROGRAM} ${WRKSRC}/testdtcl ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/testdtcl.1 ${PREFIX}/man/man1/
+ ${MKDIR} ${PREFIX}/share/doc/mod_dtcl
+ ${INSTALL_DATA} ${WRKSRC}/dtcl.tcl ${PREFIX}/share/doc/mod_dtcl
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/*.?tml ${WRKSRC}/*.gif \
+ ${PREFIX}/share/doc/mod_dtcl
+ ${CAT} ${PKGMESSAGE}
+.else
+ # Not installing the documentation. Consult the
+ # file:/${WRKSRC}/INSTALL.html
+ # for information on how to proceed to enable mod_dtcl.
+ # Note, that the dtcl.tcl mentioned there is installed as
+ # ${PREFIX}/share/doc/mod_dtcl/dtcl.tcl
+ # but the comment in it suggests it should not be used
+ # in a "production environment"...
+.endif
+ @ ${SH} ${PKGINSTALL}
+
+.include <bsd.port.mk>