aboutsummaryrefslogtreecommitdiff
path: root/www/mod_dtcl/files
diff options
context:
space:
mode:
authorChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-22 22:34:07 +0000
committerChris D. Faulhaber <jedgar@FreeBSD.org>2000-02-22 22:34:07 +0000
commit510ecb498f70089e586d83bb3ed7b68a5151bd39 (patch)
tree8f384af46ae0bd00f9ec231d29883ba2f8caef50 /www/mod_dtcl/files
parent2ac4cc452d6f063713dac994b390ce326eba0852 (diff)
downloadports-510ecb498f70089e586d83bb3ed7b68a5151bd39.tar.gz
ports-510ecb498f70089e586d83bb3ed7b68a5151bd39.zip
Notes
Diffstat (limited to 'www/mod_dtcl/files')
-rw-r--r--www/mod_dtcl/files/Makefile.bsd1
-rw-r--r--www/mod_dtcl/files/patch-aa12
2 files changed, 10 insertions, 3 deletions
diff --git a/www/mod_dtcl/files/Makefile.bsd b/www/mod_dtcl/files/Makefile.bsd
index 23427ec2f0e5..d3587aa965e7 100644
--- a/www/mod_dtcl/files/Makefile.bsd
+++ b/www/mod_dtcl/files/Makefile.bsd
@@ -9,6 +9,7 @@ INCLUDES=-I${PREFIX}/include/apache -I${PREFIX}/include/tcl${TCL_VERSION}
CC!= ${PREFIX}/sbin/apxs -q CC
CFLAGS!= ${PREFIX}/sbin/apxs -q CFLAGS CFLAGS_SHLIB
CFLAGS+= -Wall -DSTATUS -DNO_DBM_REWRITEMAP ${INCLUDES}
+CFLAGS+= -DDEBUG_SCRIPT_DIR="\"${PREFIX}/share/mod_dtcl/\""
LIB= mod_dtcl
SHLIB_MAJOR=1
diff --git a/www/mod_dtcl/files/patch-aa b/www/mod_dtcl/files/patch-aa
index 86f3aa87f6cd..05fee8a9fcb8 100644
--- a/www/mod_dtcl/files/patch-aa
+++ b/www/mod_dtcl/files/patch-aa
@@ -1,12 +1,18 @@
---- testdtcl.c.orig Mon Oct 18 10:29:02 1999
-+++ testdtcl.c Sun Jan 9 19:13:53 2000
+--- testdtcl.c.orig Mon Dec 6 00:26:28 1999
++++ testdtcl.c Thu Feb 17 15:01:52 2000
@@ -14,4 +14,5 @@
#include <tcl.h>
#include <unistd.h>
+#include <stdlib.h> /* In older FreeBSD, this is where getopt(3) lives */
#ifndef DEBUG_SCRIPT_DIR
-@@ -229,4 +230,5 @@
+@@ -51,5 +52,4 @@
+ "Testdtcl is out of date, you should only "
+ "really be using it if you wish to improve it\n");
+- exit(0);
+
+ interp = Tcl_CreateInterp();
+@@ -233,4 +233,5 @@
}
}
+ return 0;