aboutsummaryrefslogtreecommitdiff
path: root/www/mod_dtcl/files
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2009-04-12 03:13:35 +0000
committerMikhail Teterin <mi@FreeBSD.org>2009-04-12 03:13:35 +0000
commitc75c3330d16a22dc147a2d9b37d641bb94cbe50c (patch)
tree8e3e73e32a708eb2755cb5f9db93359376045e26 /www/mod_dtcl/files
parent62e49bb3a94cfe3e700b7d5c494a35c18af0e425 (diff)
downloadports-c75c3330d16a22dc147a2d9b37d641bb94cbe50c.tar.gz
ports-c75c3330d16a22dc147a2d9b37d641bb94cbe50c.zip
Notes
Diffstat (limited to 'www/mod_dtcl/files')
-rw-r--r--www/mod_dtcl/files/Makefile.bsd3
-rw-r--r--www/mod_dtcl/files/patch-warning53
2 files changed, 55 insertions, 1 deletions
diff --git a/www/mod_dtcl/files/Makefile.bsd b/www/mod_dtcl/files/Makefile.bsd
index 5affd6b0be20..a87cc2e76251 100644
--- a/www/mod_dtcl/files/Makefile.bsd
+++ b/www/mod_dtcl/files/Makefile.bsd
@@ -19,6 +19,7 @@ SRCS= mod_dtcl.c
SRCS+= apache_cookie.c apache_multipart_buffer.c apache_request.c \
channel.c parser.c tcl_commands.c
-NOMAN= True # don't bother with the man-page here, let the port handle it
+NO_MAN= True # don't bother with the man-page here, let the port handle it
+WARNS= 2
.include <bsd.lib.mk>
diff --git a/www/mod_dtcl/files/patch-warning b/www/mod_dtcl/files/patch-warning
new file mode 100644
index 000000000000..0b0341eaa3f1
--- /dev/null
+++ b/www/mod_dtcl/files/patch-warning
@@ -0,0 +1,53 @@
+--- mod_dtcl.h 2002-06-26 09:12:43.000000000 -0400
++++ mod_dtcl.h 2009-04-11 22:49:00.000000000 -0400
+@@ -100,5 +100,5 @@
+ int set_header_type(request_rec *, char *);
+ int print_headers(request_rec *);
+-int print_error(request_rec *, int, char *);
++int print_error(request_rec *, int, const char *);
+ int flush_output_buffer(request_rec *);
+ char *StringToUtf(char *input, ap_pool *pool);
+--- mod_dtcl.c 2002-04-18 09:02:19.000000000 -0400
++++ mod_dtcl.c 2009-04-11 22:48:20.000000000 -0400
+@@ -131,5 +131,6 @@
+ /* Print nice HTML formatted errors */
+
+-int print_error(request_rec *r, int htmlflag, char *errstr)
++int
++print_error(request_rec *r, int htmlflag, const char *errstr)
+ {
+ set_header_type(r, DEFAULT_HEADER_TYPE);
+@@ -314,5 +315,4 @@
+ static int execute_and_check(Tcl_Interp *interp, Tcl_Obj *outbuf, request_rec *r)
+ {
+- char *errorinfo;
+ dtcl_server_conf *conf = NULL;
+
+@@ -331,6 +331,5 @@
+ } else {
+ /* default action */
+- errorinfo = Tcl_GetVar(interp, "errorInfo", 0);
+- print_error(r, 0, errorinfo);
++ print_error(r, 0, Tcl_GetVar(interp, "errorInfo", 0));
+ print_error(r, 1, "<p><b>OUTPUT BUFFER:</b></p>");
+ print_error(r, 0, Tcl_GetStringFromObj(outbuf, (int *)NULL));
+--- channel.c 2001-09-05 08:01:22.000000000 -0400
++++ channel.c 2009-04-11 23:03:43.000000000 -0400
+@@ -19,5 +19,6 @@
+ Channel that we create to divert stdout to */
+
+-static int outputproc(ClientData instancedata, char *buf, int toWrite, int *errorCodePtr)
++static int
++outputproc(ClientData instancedata, const char *buf, int toWrite, int *errorCodePtr)
+ {
+ dtcl_server_conf *dsc = (dtcl_server_conf *)instancedata;
+@@ -34,6 +35,7 @@
+ }
+
+-static int setoptionproc(ClientData instancedata, Tcl_Interp *interp,
+- char *optionname, char *value)
++static int
++setoptionproc(ClientData instancedata, Tcl_Interp *interp,
++ const char *optionname, const char *value)
+ {
+ return TCL_OK;