aboutsummaryrefslogtreecommitdiff
path: root/www/mod_extract_forwarded_ap13/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-06-19 01:59:10 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-06-19 01:59:10 +0000
commitbf4b2173ef0aea76fe2eb4ee33e571203d6b4fc9 (patch)
tree51156aaecd82a0ebe838fcf37b07fe59213bb224 /www/mod_extract_forwarded_ap13/Makefile
parent150a7b6b49aa315dbe56c85349dd30275e8236d9 (diff)
downloadports-bf4b2173ef0aea76fe2eb4ee33e571203d6b4fc9.tar.gz
ports-bf4b2173ef0aea76fe2eb4ee33e571203d6b4fc9.zip
Notes
Diffstat (limited to 'www/mod_extract_forwarded_ap13/Makefile')
-rw-r--r--www/mod_extract_forwarded_ap13/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/www/mod_extract_forwarded_ap13/Makefile b/www/mod_extract_forwarded_ap13/Makefile
new file mode 100644
index 000000000000..3081d06a2c4b
--- /dev/null
+++ b/www/mod_extract_forwarded_ap13/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: mod_extract_forwarded
+# Date created: 9 June 2001
+# Whom: Anders Nordby <anders@fix.no>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_extract_forwarded
+PORTVERSION= 1.2
+CATEGORIES= www
+MASTER_SITES= http://web.systhug.com/mod_extract_forwarded/ \
+ http://www.freenix.no/~anders/
+
+MAINTAINER= anders@fix.no
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+DOCS= mod_extract_forwarded.html README
+
+do-build:
+ cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+
+do-install:
+ cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.so
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${PREFIX}/share/doc/${PORTNAME}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/${PORTNAME}
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>