aboutsummaryrefslogtreecommitdiff
path: root/www/mod_fastcgi
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-01-18 04:31:26 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2012-01-18 04:31:26 +0000
commit5afc4c67578a7307a21a229a9b5a97b9af0c811d (patch)
tree8f310676d96ba983819a1c874609e18b7430bbb4 /www/mod_fastcgi
parent91fae18456ded20e005bcf208bfc13ee754083a0 (diff)
downloadports-5afc4c67578a7307a21a229a9b5a97b9af0c811d.tar.gz
ports-5afc4c67578a7307a21a229a9b5a97b9af0c811d.zip
Notes
Diffstat (limited to 'www/mod_fastcgi')
-rw-r--r--www/mod_fastcgi/Makefile5
-rw-r--r--www/mod_fastcgi/files/patch-mod_fastcgi.c14
2 files changed, 18 insertions, 1 deletions
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index 3bf7e740aa93..1c81c873cbce 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_fastcgi
PORTVERSION= 2.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://www.fastcgi.com/dist/
@@ -23,6 +23,9 @@ AP_GENPLIST= yes
SRC_FILE= *.c
PORTDOCS= LICENSE.TERMS mod_fastcgi.html
+do-install:
+ @${APXS} -i -a -n ${SHORTMODNAME} ${WRKSRC}/${MODULENAME}.${AP_BUILDEXT}
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/www/mod_fastcgi/files/patch-mod_fastcgi.c b/www/mod_fastcgi/files/patch-mod_fastcgi.c
new file mode 100644
index 000000000000..4491acc6820f
--- /dev/null
+++ b/www/mod_fastcgi/files/patch-mod_fastcgi.c
@@ -0,0 +1,14 @@
+--- mod_fastcgi.c.orig 2011-12-12 15:37:24.211384000 +0800
++++ mod_fastcgi.c 2011-12-12 15:37:50.565004000 +0800
+@@ -754,6 +754,11 @@
+ continue;
+ }
+
++ if (strcasecmp(name, "Content-Length") == 0) {
++ ap_set_content_length(r, strtol(value, NULL, 10));
++ continue;
++ }
++
+ /* If the script wants them merged, it can do it */
+ ap_table_add(r->err_headers_out, name, value);
+ continue;