aboutsummaryrefslogtreecommitdiff
path: root/www/mod_fastcgi
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2013-03-27 18:17:22 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2013-03-27 18:17:22 +0000
commit7d5bf1875eda8c850b0243c91db382956e9ded00 (patch)
tree06d087eb96ffb293464058f104f8b7c52eca8880 /www/mod_fastcgi
parentb1263f67568e55679224fdfd5bce7f9fb66e2368 (diff)
downloadports-7d5bf1875eda8c850b0243c91db382956e9ded00.tar.gz
ports-7d5bf1875eda8c850b0243c91db382956e9ded00.zip
Notes
Diffstat (limited to 'www/mod_fastcgi')
-rw-r--r--www/mod_fastcgi/Makefile9
-rw-r--r--www/mod_fastcgi/distinfo4
-rw-r--r--www/mod_fastcgi/files/patch-mod_fastcgi.c26
3 files changed, 29 insertions, 10 deletions
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index 003620bd671e..30f4cfe62a25 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -2,17 +2,18 @@
# $FreeBSD$
PORTNAME= mod_fastcgi
-PORTVERSION= 2.4.6
-PORTREVISION= 3
+PORTVERSION= 2.4.7
CATEGORIES= www
-MASTER_SITES= http://www.fastcgi.com/dist/
+MASTER_SITES= http://www.fastcgi.com/dist/ \
+ LOCAL/ohauer
+DISTNAME= mod_fastcgi-SNAP-0910052141
+DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
COMMENT= A fast-cgi module for Apache
MAKE_JOBS_SAFE= yes
-CONFLICTS= apache-contrib-1.*
USE_APACHE= 22
AP_FAST_BUILD= yes
AP_GENPLIST= yes
diff --git a/www/mod_fastcgi/distinfo b/www/mod_fastcgi/distinfo
index 3f3f0b33efef..ea1ef98ef0ef 100644
--- a/www/mod_fastcgi/distinfo
+++ b/www/mod_fastcgi/distinfo
@@ -1,2 +1,2 @@
-SHA256 (mod_fastcgi-2.4.6.tar.gz) = a5a887eecc8fe13e4cb1cab4d140188a3d2b5e6f337f8a1cce88ca441ddbe689
-SIZE (mod_fastcgi-2.4.6.tar.gz) = 100230
+SHA256 (apache2/mod_fastcgi-SNAP-0910052141.tar.gz) = e6564ae206284806c781834e9e89aa4b0a4dd647b45c6da5cc389c65a984bdc7
+SIZE (apache2/mod_fastcgi-SNAP-0910052141.tar.gz) = 103255
diff --git a/www/mod_fastcgi/files/patch-mod_fastcgi.c b/www/mod_fastcgi/files/patch-mod_fastcgi.c
index 4491acc6820f..5fc79fcf891c 100644
--- a/www/mod_fastcgi/files/patch-mod_fastcgi.c
+++ b/www/mod_fastcgi/files/patch-mod_fastcgi.c
@@ -1,7 +1,7 @@
---- mod_fastcgi.c.orig 2011-12-12 15:37:24.211384000 +0800
-+++ mod_fastcgi.c 2011-12-12 15:37:50.565004000 +0800
-@@ -754,6 +754,11 @@
- continue;
+--- ./mod_fastcgi.c.orig 2008-11-09 15:31:03.000000000 +0100
++++ ./mod_fastcgi.c 2013-03-27 18:51:40.000000000 +0100
+@@ -753,6 +753,11 @@
+ continue;
}
+ if (strcasecmp(name, "Content-Length") == 0) {
@@ -12,3 +12,21 @@
/* If the script wants them merged, it can do it */
ap_table_add(r->err_headers_out, name, value);
continue;
+@@ -2215,7 +2220,7 @@
+ if (select_status < 0)
+ {
+ ap_log_rerror(FCGI_LOG_ERR_ERRNO, r, "FastCGI: comm with server "
+- "\"%s\" aborted: select() failed", fr->fs_path);
++ "\"%s\" aborted: select() failed: \"%s\"", fr->fs_path, strerror(errno));
+ state = STATE_ERROR;
+ break;
+ }
+@@ -2298,7 +2303,7 @@
+ else
+ {
+ ap_log_rerror(FCGI_LOG_ERR, r, "FastCGI: comm with server "
+- "\"%s\" aborted: read failed", fr->fs_path);
++ "\"%s\" aborted: read failed: \"%s\"", fr->fs_path, strerror(errno));
+ state = STATE_ERROR;
+ break;
+ }