aboutsummaryrefslogtreecommitdiff
path: root/www/mod_fastcgi
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-05-31 10:45:56 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-05-31 10:45:56 +0000
commitb2357b495c37d7f03aad45853e66ffaa009e88ac (patch)
tree3fa45848577175d2bf267a8aeaf4acb543e33a58 /www/mod_fastcgi
parent1a00e2a5e48443a0d1565ee0abf33727dd13e52e (diff)
downloadports-b2357b495c37d7f03aad45853e66ffaa009e88ac.tar.gz
ports-b2357b495c37d7f03aad45853e66ffaa009e88ac.zip
Notes
Diffstat (limited to 'www/mod_fastcgi')
-rw-r--r--www/mod_fastcgi/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/mod_fastcgi/Makefile b/www/mod_fastcgi/Makefile
index ff1cbba9d5d0..f4ea71250f50 100644
--- a/www/mod_fastcgi/Makefile
+++ b/www/mod_fastcgi/Makefile
@@ -28,6 +28,10 @@ PLIST_SUB= APACHE=2
PLIST_SUB= APACHE=
.endif
+.if defined(WITHOUT_APACHE_SUEXEC)
+APXSOPTS+= -DNO_SUEXEC_FOR_AP_USER_N_GROUP
+.endif
+
do-patch:
.if defined(WITH_APACHE2)
@${REINPLACE_CMD} -e "s|/usr/local/apache2|${PREFIX}/share/apache2|g" ${WRKSRC}/${MAKEFILE}
@@ -35,7 +39,7 @@ do-patch:
cd ${WRKSRC} ; ${MV} Makefile.tmpl Makefile ;
do-build:
- cd ${WRKSRC} ; ${LOCALBASE}/sbin/apxs -o mod_fastcgi.so -c *.c
+ cd ${WRKSRC} ; ${LOCALBASE}/sbin/apxs -o mod_fastcgi.so -c ${APXSOPT} *.c
do-install:
cd ${WRKSRC} ; ${LOCALBASE}/sbin/apxs -i -a -n fastcgi mod_fastcgi.so