aboutsummaryrefslogtreecommitdiff
path: root/www/mod_fcgid
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2004-08-12 20:51:15 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2004-08-12 20:51:15 +0000
commita937c65931ac9e852c6fc91eb366f0240b4d2887 (patch)
tree2e141e6c9d9ba2419c5f86383c53d2eecc43c3bf /www/mod_fcgid
parent0665a0ab4e145637a03a26366ac68a7a95672fb5 (diff)
downloadports-a937c65931ac9e852c6fc91eb366f0240b4d2887.tar.gz
ports-a937c65931ac9e852c6fc91eb366f0240b4d2887.zip
Notes
Diffstat (limited to 'www/mod_fcgid')
-rw-r--r--www/mod_fcgid/Makefile27
-rw-r--r--www/mod_fcgid/distinfo2
-rw-r--r--www/mod_fcgid/files/patch-fcgid_conf.c11
-rw-r--r--www/mod_fcgid/files/patch-fcgid_proc_unix.c7
-rw-r--r--www/mod_fcgid/pkg-descr12
-rw-r--r--www/mod_fcgid/pkg-message10
-rw-r--r--www/mod_fcgid/pkg-plist4
7 files changed, 73 insertions, 0 deletions
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
new file mode 100644
index 000000000000..9254b2cd378b
--- /dev/null
+++ b/www/mod_fcgid/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: mod_fcgid for Apache2
+# Date created: 13 August 2004
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_fcgid
+PORTVERSION= 0.80
+CATEGORIES= www
+MASTER_SITES= http://fastcgi.coremail.cn/
+DISTNAME= ${PORTNAME}.${PORTVERSION}
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= An alternative FastCGI module for Apache2
+
+USE_APACHE= yes
+WITH_APACHE2= yes
+MAKE_ARGS= top_dir="${LOCALBASE}/share/apache2" INCLUDES="-I${LOCALBASE}/include/apache2"
+INSTALL_TARGET= install-modules
+
+post-install:
+ ${MKDIR} -m 700 /var/run/fcgidsock
+ ${CHOWN} www:www /var/run/fcgidsock
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_fcgid/distinfo b/www/mod_fcgid/distinfo
new file mode 100644
index 000000000000..f69170e65191
--- /dev/null
+++ b/www/mod_fcgid/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_fcgid.0.80.tar.gz) = 553cf737f242cc657d9fab0c6e62602f
+SIZE (mod_fcgid.0.80.tar.gz) = 43616
diff --git a/www/mod_fcgid/files/patch-fcgid_conf.c b/www/mod_fcgid/files/patch-fcgid_conf.c
new file mode 100644
index 000000000000..6255ce049ecc
--- /dev/null
+++ b/www/mod_fcgid/files/patch-fcgid_conf.c
@@ -0,0 +1,11 @@
+--- fcgid_conf.c.orig Mon Jul 26 07:08:03 2004
++++ fcgid_conf.c Fri Aug 13 05:04:44 2004
+@@ -15,7 +15,7 @@
+ #define DEFAULT_ERROR_SCAN_INTERVAL 3
+ #define DEFAULT_ZOMBIE_SCAN_INTERVAL 3
+ #define DEFAULT_PROC_LIFETIME (60*60)
+-#define DEFAULT_SOCKET_PREFIX "logs/fcgidsock"
++#define DEFAULT_SOCKET_PREFIX "/var/run/fcgidsock"
+ #define DEFAULT_SPAWNSOCRE_UPLIMIT 10
+ #define DEFAULT_SPAWN_SCORE 1
+ #define DEFAULT_TERMINATION_SCORE 2
diff --git a/www/mod_fcgid/files/patch-fcgid_proc_unix.c b/www/mod_fcgid/files/patch-fcgid_proc_unix.c
new file mode 100644
index 000000000000..a3dbe8ba2ef5
--- /dev/null
+++ b/www/mod_fcgid/files/patch-fcgid_proc_unix.c
@@ -0,0 +1,7 @@
+--- arch/unix/fcgid_proc_unix.c.orig Mon Jul 26 07:08:03 2004
++++ arch/unix/fcgid_proc_unix.c Fri Aug 13 04:53:49 2004
+@@ -1,3 +1,4 @@
++#include <sys/types.h>
+ #include <sys/un.h>
+ #include "httpd.h"
+ #include "apr_thread_proc.h"
diff --git a/www/mod_fcgid/pkg-descr b/www/mod_fcgid/pkg-descr
new file mode 100644
index 000000000000..884c78da7935
--- /dev/null
+++ b/www/mod_fcgid/pkg-descr
@@ -0,0 +1,12 @@
+mod_fcgid -- an alternative FastCGI module for Apache2
+
+mod_fcgid has a new process management strategy, which concentrates on
+reducing the number of fastcgi server, and kick out the corrupt
+fastcgi server as soon as possible.
+
+The bad news is that it does not currently support suEXEC, and the
+good news is that it has PHP support. Check out the web site for
+details.
+
+Licence: GPL
+WWW: http://fastcgi.coremail.cn/
diff --git a/www/mod_fcgid/pkg-message b/www/mod_fcgid/pkg-message
new file mode 100644
index 000000000000..17a13263fc35
--- /dev/null
+++ b/www/mod_fcgid/pkg-message
@@ -0,0 +1,10 @@
+************************************************************
+To enable this module, add something like the following
+lines to your server configuration file:
+
+ LoadModule fcgid_module libexec/apache2/mod_fcgid.so
+
+ <IfModule mod_fcgid.c>
+ AddHandler fcgid-script .fcgi
+ </IfModule>
+************************************************************
diff --git a/www/mod_fcgid/pkg-plist b/www/mod_fcgid/pkg-plist
new file mode 100644
index 000000000000..bc85ebc4c2fc
--- /dev/null
+++ b/www/mod_fcgid/pkg-plist
@@ -0,0 +1,4 @@
+libexec/apache2/mod_fcgid.so
+@exec /bin/mkdir -p -m 700 /var/run/fcgidsock
+@exec /bin/chown www:www /var/run/fcgidsock
+@unexec /bin/rmdir /var/run/fcgidsock 2>/dev/null || true