aboutsummaryrefslogtreecommitdiff
path: root/www/mod_flickr
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-13 12:34:31 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-13 12:34:31 +0000
commit94670b07da73d54ae2ab0c15c9fc9ebb28f99da1 (patch)
treec380917c9a6d449e2350f9768df1a2edec875dc5 /www/mod_flickr
parentbad12b112dffe2458f59c5c3148e22e84d7a0f06 (diff)
downloadports-94670b07da73d54ae2ab0c15c9fc9ebb28f99da1.tar.gz
ports-94670b07da73d54ae2ab0c15c9fc9ebb28f99da1.zip
Notes
Diffstat (limited to 'www/mod_flickr')
-rw-r--r--www/mod_flickr/Makefile34
-rw-r--r--www/mod_flickr/distinfo3
-rw-r--r--www/mod_flickr/pkg-descr14
3 files changed, 51 insertions, 0 deletions
diff --git a/www/mod_flickr/Makefile b/www/mod_flickr/Makefile
new file mode 100644
index 000000000000..e2b4a84c237f
--- /dev/null
+++ b/www/mod_flickr/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: mod_flickr
+# Date created: 2009-08-24
+# Whom: vshankar
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_flickr
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.vshank.com/modcode/
+
+MAINTAINER= venkyshankar@yahoo.com
+COMMENT= Apache module for Flickr API access
+
+LIB_DEPENDS= curl.5:${PORTSDIR}/ftp/curl
+
+XTRA_FLAGS= -lcurl
+
+AP_INC= ${LOCALBASE}/include
+AP_LIB= ${LOCALBASE}/lib
+
+.if defined(WITH_DEBUG)
+XTRA_FLAGS+= -DDEBUG
+.endif
+
+AP_EXTRAS= ${XTRA_FLAGS}
+USE_LDCONFIG= yes
+
+USE_APACHE= 2.0+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/www/mod_flickr/distinfo b/www/mod_flickr/distinfo
new file mode 100644
index 000000000000..0091d18ab110
--- /dev/null
+++ b/www/mod_flickr/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_flickr-1.0.tar.gz) = 029e7263043de04252d683a91185ff79
+SHA256 (mod_flickr-1.0.tar.gz) = b43ab4cc9332462e6d4c37dbe3aa8ed0d9d9e3fb87a405d8d9c264c2b039aab6
+SIZE (mod_flickr-1.0.tar.gz) = 10634
diff --git a/www/mod_flickr/pkg-descr b/www/mod_flickr/pkg-descr
new file mode 100644
index 000000000000..b7b7938fc424
--- /dev/null
+++ b/www/mod_flickr/pkg-descr
@@ -0,0 +1,14 @@
+mod_flickr is a apache module (for apache 2.0 and above) that makes call to
+flickr via flickr API's to get a users (configured in httpd.conf) public photo
+sets, photos in sets and recent photos uploaded in flickr etc...
+
+Currently only 4 api calls have been implmeneted (all are GET calls). These
+API's return data in XML format. The XML can then be parsed by the calling code
+(e.g. front end Javascript/php) to display thumbnails of the images say in a
+scrollbar. (Code for front end is not distributed as yet)
+
+This module can be used by web developers who want to show their photos/albums
+uploaded in flickr on their website and/or access to metadata of their photos
+for their own needs/purposes.
+
+WWW: http://www.vshank.com/code/mod_flickr