aboutsummaryrefslogtreecommitdiff
path: root/www/mod_gzip2/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2008-06-30 04:54:04 +0000
committerXin LI <delphij@FreeBSD.org>2008-06-30 04:54:04 +0000
commitf6ae7b0cc9cfe4c11c497358f1ebbaa2a235113d (patch)
treeaea10192b2375953aa3fb64c2865668070c2b365 /www/mod_gzip2/Makefile
parentb994047b690d85c9d9f353ba440e0458b902fecf (diff)
Notes
Diffstat (limited to 'www/mod_gzip2/Makefile')
-rw-r--r--www/mod_gzip2/Makefile32
1 files changed, 16 insertions, 16 deletions
diff --git a/www/mod_gzip2/Makefile b/www/mod_gzip2/Makefile
index a9582444c26e..ef08acd98592 100644
--- a/www/mod_gzip2/Makefile
+++ b/www/mod_gzip2/Makefile
@@ -1,34 +1,34 @@
-# New ports collection makefile for: mod_gzip Apache module
-# Date created: Dec 13 2000
-# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+# New ports collection makefile for: mod_gzip2 Apache module
+# Date created: 2008-06-27
+# Whom: Stefan `Sec` Zehl <sec@42.org>
#
# $FreeBSD$
#
-PORTNAME= mod_gzip
-PORTVERSION= 1.3.26.1a
+PORTNAME= mod_gzip2
+PORTVERSION= 2.1.0
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= mod-gzip
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.gknw.net/development/apache/httpd-2.0/unix/modules/
+DISTNAME= mod_gzip-${PORTVERSION}
-MAINTAINER= ale@FreeBSD.org
-COMMENT= An Internet Content Acceleration module for Apache
+MAINTAINER= sec@42.org
+COMMENT= An Internet Content Acceleration module for Apache2+
-USE_APACHE= yes
+USE_APACHE= 2.0+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
MAKE_ENV+= "APXS=${APXS}"
-ALL_TARGET= build
+USE_GMAKE= yes
post-patch:
- @${REINPLACE_CMD} 's|-Wc,-Wall,-O3,-fomit-frame-pointer,-pipe||' \
- ${WRKSRC}/Makefile
+ @${MV} ${WRKSRC}/mod_gzip.c ${WRKSRC}/${PORTNAME}.c
post-install:
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/mod_gzip.conf.sample ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/my_cfg.txt ${EXAMPLESDIR}/mod_gzip2.conf.sample
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/manual/english/* ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/commands.txt ${WRKSRC}/samples.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>