aboutsummaryrefslogtreecommitdiff
path: root/www/mod_gzip2
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2008-06-30 04:54:04 +0000
committerXin LI <delphij@FreeBSD.org>2008-06-30 04:54:04 +0000
commitf6ae7b0cc9cfe4c11c497358f1ebbaa2a235113d (patch)
treeaea10192b2375953aa3fb64c2865668070c2b365 /www/mod_gzip2
parentb994047b690d85c9d9f353ba440e0458b902fecf (diff)
downloadports-f6ae7b0cc9cfe4c11c497358f1ebbaa2a235113d.tar.gz
ports-f6ae7b0cc9cfe4c11c497358f1ebbaa2a235113d.zip
Notes
Diffstat (limited to 'www/mod_gzip2')
-rw-r--r--www/mod_gzip2/Makefile32
-rw-r--r--www/mod_gzip2/distinfo6
-rw-r--r--www/mod_gzip2/files/patch-Makefile24
-rw-r--r--www/mod_gzip2/files/patch-mod_gzip10
-rw-r--r--www/mod_gzip2/files/patch-zutil.h68
-rw-r--r--www/mod_gzip2/pkg-descr7
-rw-r--r--www/mod_gzip2/pkg-plist25
7 files changed, 129 insertions, 43 deletions
diff --git a/www/mod_gzip2/Makefile b/www/mod_gzip2/Makefile
index a9582444c26e..ef08acd98592 100644
--- a/www/mod_gzip2/Makefile
+++ b/www/mod_gzip2/Makefile
@@ -1,34 +1,34 @@
-# New ports collection makefile for: mod_gzip Apache module
-# Date created: Dec 13 2000
-# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+# New ports collection makefile for: mod_gzip2 Apache module
+# Date created: 2008-06-27
+# Whom: Stefan `Sec` Zehl <sec@42.org>
#
# $FreeBSD$
#
-PORTNAME= mod_gzip
-PORTVERSION= 1.3.26.1a
+PORTNAME= mod_gzip2
+PORTVERSION= 2.1.0
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= mod-gzip
-EXTRACT_SUFX= .tgz
+MASTER_SITES= http://www.gknw.net/development/apache/httpd-2.0/unix/modules/
+DISTNAME= mod_gzip-${PORTVERSION}
-MAINTAINER= ale@FreeBSD.org
-COMMENT= An Internet Content Acceleration module for Apache
+MAINTAINER= sec@42.org
+COMMENT= An Internet Content Acceleration module for Apache2+
-USE_APACHE= yes
+USE_APACHE= 2.0+
+AP_FAST_BUILD= yes
+AP_GENPLIST= yes
MAKE_ENV+= "APXS=${APXS}"
-ALL_TARGET= build
+USE_GMAKE= yes
post-patch:
- @${REINPLACE_CMD} 's|-Wc,-Wall,-O3,-fomit-frame-pointer,-pipe||' \
- ${WRKSRC}/Makefile
+ @${MV} ${WRKSRC}/mod_gzip.c ${WRKSRC}/${PORTNAME}.c
post-install:
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/mod_gzip.conf.sample ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/my_cfg.txt ${EXAMPLESDIR}/mod_gzip2.conf.sample
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/docs/manual/english/* ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/commands.txt ${WRKSRC}/samples.txt ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/www/mod_gzip2/distinfo b/www/mod_gzip2/distinfo
index 46c5448cd6bc..1e34b3bf7fb3 100644
--- a/www/mod_gzip2/distinfo
+++ b/www/mod_gzip2/distinfo
@@ -1,3 +1,3 @@
-MD5 (mod_gzip-1.3.26.1a.tgz) = 080ccc5d789ed5efa0c0a7625e4fa02d
-SHA256 (mod_gzip-1.3.26.1a.tgz) = db9dd1c621f86d19145a2d7e9ad255f54fad067924744926478f9e72e8deaef5
-SIZE (mod_gzip-1.3.26.1a.tgz) = 137394
+MD5 (mod_gzip-2.1.0.tar.gz) = 9011aa2dc4701c0301e6c608269f8835
+SHA256 (mod_gzip-2.1.0.tar.gz) = 56bb3dafd0adc7ebf54fedf1f120974c3ea8bf3eb6190daf3baf393543718fdd
+SIZE (mod_gzip-2.1.0.tar.gz) = 76887
diff --git a/www/mod_gzip2/files/patch-Makefile b/www/mod_gzip2/files/patch-Makefile
new file mode 100644
index 000000000000..b97a7e94ec0b
--- /dev/null
+++ b/www/mod_gzip2/files/patch-Makefile
@@ -0,0 +1,24 @@
+--- Makefile.org 2005-05-12 04:25:40.000000000 +0200
++++ Makefile 2008-06-27 01:08:33.000000000 +0200
+@@ -2,17 +2,17 @@
+ TARGET=mod_gzip
+
+ # the used tools
+-APXS=/usr/local/apache2/bin/apxs
++#APXS=/usr/local/apache2/bin/apxs
+ APACHECTL=/usr/local/apache2/bin/apachectl
+
+ # additional defines, includes and libraries
+-LIBDIR=/usr/lib
++#LIBDIR=/usr/lib
+ #INC=-I/usr/include/zlib
+ LIB=-lz -L$(LIBDIR)
+
+ # the default target
+-OPT=-Wc,-Wall
+-OPT+=-Wl,--rpath -Wl,$(LIBDIR)
++#OPT=-Wc,-Wall
++#OPT+=-Wl,--rpath -Wl,$(LIBDIR)
+
+ # the default target
+ all: $(TARGET).la
diff --git a/www/mod_gzip2/files/patch-mod_gzip b/www/mod_gzip2/files/patch-mod_gzip
new file mode 100644
index 000000000000..764a830b00b6
--- /dev/null
+++ b/www/mod_gzip2/files/patch-mod_gzip
@@ -0,0 +1,10 @@
+--- mod_gzip.c.org 2005-05-11 03:13:14.000000000 +0200
++++ mod_gzip.c 2008-06-27 01:13:37.000000000 +0200
+@@ -86,6 +86,7 @@
+ /* included automatically at this point in a pre-2.0 compile... */
+
+ #include <sys/stat.h> /* For stat() call */
++#include <unistd.h>
+
+ /* Version information... */
+
diff --git a/www/mod_gzip2/files/patch-zutil.h b/www/mod_gzip2/files/patch-zutil.h
new file mode 100644
index 000000000000..1049cdfbb13d
--- /dev/null
+++ b/www/mod_gzip2/files/patch-zutil.h
@@ -0,0 +1,68 @@
+--- /dev/null 2008-06-29 21:37:16.000000000 -0700
++++ zutil.h 2008-06-29 21:37:12.114407940 -0700
+@@ -0,0 +1,65 @@
++/* zutil.h -- stripped version just containing OS_CODE
++ * Copyright (C) 1995-2005 Jean-loup Gailly.
++ * For conditions of distribution and use, see copyright notice in zlib.h
++ */
++
++/* WARNING: this file should *not* be used by applications. It is
++ part of the implementation of the compression library and is
++ subject to change. Applications should only use zlib.h.
++ */
++
++#ifndef ZUTIL_H
++#define ZUTIL_H
++
++#define ZLIB_INTERNAL
++#include "zlib.h"
++
++ /* target dependencies */
++
++#if defined(MSDOS) || (defined(WINDOWS) && !defined(WIN32))
++# define OS_CODE 0x00
++#endif
++
++#ifdef AMIGA
++# define OS_CODE 0x01
++#endif
++
++#if defined(VAXC) || defined(VMS)
++# define OS_CODE 0x02
++#endif
++
++#if defined(ATARI) || defined(atarist)
++# define OS_CODE 0x05
++#endif
++
++#ifdef OS2
++# define OS_CODE 0x06
++# ifdef M_I86
++ #include <malloc.h>
++# endif
++#endif
++
++#if defined(MACOS) || defined(TARGET_OS_MAC)
++# define OS_CODE 0x07
++#endif
++
++#ifdef TOPS20
++# define OS_CODE 0x0a
++#endif
++
++#ifdef WIN32
++# ifndef __CYGWIN__ /* Cygwin is Unix, not Win32 */
++# define OS_CODE 0x0b
++# endif
++#endif
++
++#ifdef __50SERIES /* Prime/PRIMOS */
++# define OS_CODE 0x0f
++#endif
++
++ /* common defaults */
++
++#ifndef OS_CODE
++# define OS_CODE 0x03 /* assume Unix */
++#endif
++#endif
diff --git a/www/mod_gzip2/pkg-descr b/www/mod_gzip2/pkg-descr
index fa726081e469..deb424fd1d6b 100644
--- a/www/mod_gzip2/pkg-descr
+++ b/www/mod_gzip2/pkg-descr
@@ -7,7 +7,6 @@ compression libraries such as ZLIB to deliver dynamically compressed
content 'on the fly' to any browser or user-agent that is capable of
receiving it.
-WWW: http://sourceforge.net/projects/mod-gzip/
-
-- Alex Dupre
-ale@FreeBSD.org
+This is the updated mod_gzip for apache version 2.0 and above.
+It has better compression and better logging than the builtin module
+mod_deflate.
diff --git a/www/mod_gzip2/pkg-plist b/www/mod_gzip2/pkg-plist
index 45274e10e7ad..cf2612e4994f 100644
--- a/www/mod_gzip2/pkg-plist
+++ b/www/mod_gzip2/pkg-plist
@@ -1,20 +1,5 @@
-libexec/apache/mod_gzip.so
-@exec %D/sbin/apxs -e -A -n gzip %f
-@unexec %D/sbin/apxs -e -A -n gzip %f
-%%PORTDOCS%%share/doc/mod_gzip/browser.htm
-%%PORTDOCS%%share/doc/mod_gzip/cache.htm
-%%PORTDOCS%%share/doc/mod_gzip/config.htm
-%%PORTDOCS%%share/doc/mod_gzip/encoding.htm
-%%PORTDOCS%%share/doc/mod_gzip/enhancements.htm
-%%PORTDOCS%%share/doc/mod_gzip/extern.gif
-%%PORTDOCS%%share/doc/mod_gzip/firewalls.htm
-%%PORTDOCS%%share/doc/mod_gzip/index.htm
-%%PORTDOCS%%share/doc/mod_gzip/links.htm
-%%PORTDOCS%%share/doc/mod_gzip/mod_gzip_logo.gif
-%%PORTDOCS%%share/doc/mod_gzip/status.htm
-%%PORTDOCS%%share/doc/mod_gzip/valid-css.png
-%%PORTDOCS%%share/doc/mod_gzip/valid-xhtml11.png
-%%PORTDOCS%%share/doc/mod_gzip/versions.htm
-share/examples/mod_gzip/mod_gzip.conf.sample
-@dirrm share/examples/mod_gzip
-%%PORTDOCS%%@dirrm share/doc/mod_gzip
+%%PORTDOCS%%share/doc/mod_gzip2/commands.txt
+%%PORTDOCS%%share/doc/mod_gzip2/samples.txt
+share/examples/mod_gzip2/mod_gzip2.conf.sample
+@dirrm share/examples/mod_gzip2
+%%PORTDOCS%%@dirrm share/doc/mod_gzip2