aboutsummaryrefslogtreecommitdiff
path: root/www/mod_hosts_access/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2002-08-05 16:48:38 +0000
committerPete Fritchman <petef@FreeBSD.org>2002-08-05 16:48:38 +0000
commitd69eaa9d5d161bfee21ee9008c3195411d86e59d (patch)
tree8df2a20068168d731ca53e23ad34401f8f7d328a /www/mod_hosts_access/Makefile
parent7e12c5c287864189c6b87a2de0600440c8fc141e (diff)
Notes
Diffstat (limited to 'www/mod_hosts_access/Makefile')
-rw-r--r--www/mod_hosts_access/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/mod_hosts_access/Makefile b/www/mod_hosts_access/Makefile
index f3960b40cabd..24295afdac17 100644
--- a/www/mod_hosts_access/Makefile
+++ b/www/mod_hosts_access/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mod_hosts_access
PORTVERSION= 1.0.0
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.klomp.org/mod_hosts_access/
@@ -16,9 +17,10 @@ BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
APXS?= ${LOCALBASE}/sbin/apxs
+APXS_FLAGS?= -S LDFLAGS_SHLIB="-shared -lwrap"
do-build:
- @cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c
+ @cd ${WRKSRC} && ${APXS} ${APXS_FLAGS} -c ${PORTNAME}.c
do-install:
${APXS} -i -A -n ${PORTNAME:S/mod_//g} ${WRKSRC}/${PORTNAME}.so