aboutsummaryrefslogtreecommitdiff
path: root/www/mod_jail
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-10-07 22:09:32 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-10-07 22:09:32 +0000
commit04c70b4d4363561a6aadfebc6b600c0b2112b5d4 (patch)
treecdd186692b37e203cd3fdeb78eb1218a6cd58bed /www/mod_jail
parent384e66ad674bf1b56658e9a8eeda85056fa6b843 (diff)
downloadports-04c70b4d4363561a6aadfebc6b600c0b2112b5d4.tar.gz
ports-04c70b4d4363561a6aadfebc6b600c0b2112b5d4.zip
Notes
Diffstat (limited to 'www/mod_jail')
-rw-r--r--www/mod_jail/Makefile40
-rw-r--r--www/mod_jail/distinfo3
-rw-r--r--www/mod_jail/pkg-descr6
3 files changed, 49 insertions, 0 deletions
diff --git a/www/mod_jail/Makefile b/www/mod_jail/Makefile
new file mode 100644
index 000000000000..4e413679abbd
--- /dev/null
+++ b/www/mod_jail/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: mod_jail
+# Date created: Oct 7 2005
+# Whom: Frank Laszlo <laszlof@vonostingroup.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_jail
+PORTVERSION= 0.1
+CATEGORIES= www
+MASTER_SITES= http://igorpopov.newmail.ru/
+
+MAINTAINER= laszlof@vonostingroup.com
+COMMENT= Apache 1.3.x module to enable an easy alternative to mod_chroot
+
+WRKSRC= ${WRKDIR}/mod_jail
+USE_APACHE= 1.3
+AP_FAST_BUILD= YES
+AP_GENPLIST= YES
+
+PORTDOCS= changelog.html documentation.html download.html \
+ index.html
+
+.include <bsd.port.pre.mk>
+
+post-extract:
+ @${REINPLACE_CMD} -e "s|= apxs|= ${APXS}|" ${WRKSRC}/Makefile
+
+.if defined(WITH_APACHE2)
+IGNORE= only works on Apache 1.3.x
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/doc && \
+ ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_jail/distinfo b/www/mod_jail/distinfo
new file mode 100644
index 000000000000..8b74fe3565df
--- /dev/null
+++ b/www/mod_jail/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_jail-0.1.tar.gz) = be4605b172f69fcea7f6a9d43182b51c
+SHA256 (mod_jail-0.1.tar.gz) = 145c119db0c17d524ab7ee061f8b8221bb8aa472924066e2814d5e6d860d7f1c
+SIZE (mod_jail-0.1.tar.gz) = 12906
diff --git a/www/mod_jail/pkg-descr b/www/mod_jail/pkg-descr
new file mode 100644
index 000000000000..0aef5f840520
--- /dev/null
+++ b/www/mod_jail/pkg-descr
@@ -0,0 +1,6 @@
+mod_jail is Apache 1.3.xx module, that makes running Apache in a secure jail
+prison easy, so it is intended to run on FreeBSD only. It is similar to
+mod_chroot, but uses FreeBSD's specific system call - jail. Also mod_jail make
+it possible to change securelevel into jail prison.
+
+WWW: http://igorpopov.newmail.ru/mod_jail/