aboutsummaryrefslogtreecommitdiff
path: root/www/mod_jk2/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-18 10:33:14 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-18 10:33:14 +0000
commit396e6c634d00e9e5e8f63cab0f45f069a720bdc5 (patch)
tree3b054ac3e42090be0ee061ff67848fc40f8c5a77 /www/mod_jk2/Makefile
parent1004432606ddcca74a97eb41052fdf0ed5855e05 (diff)
downloadports-396e6c634d00e9e5e8f63cab0f45f069a720bdc5.tar.gz
ports-396e6c634d00e9e5e8f63cab0f45f069a720bdc5.zip
Notes
Diffstat (limited to 'www/mod_jk2/Makefile')
-rw-r--r--www/mod_jk2/Makefile69
1 files changed, 45 insertions, 24 deletions
diff --git a/www/mod_jk2/Makefile b/www/mod_jk2/Makefile
index f17b7f97df8a..d8c3fe13a030 100644
--- a/www/mod_jk2/Makefile
+++ b/www/mod_jk2/Makefile
@@ -1,38 +1,59 @@
-# New ports collection makefile for: mod_jk
-# Date created: Thu Apr 10 15:14:37 EDT 2003
-# Whom: Larry Lansing <lansil@fuzzynerd.com>
+# New ports collection makefile for: mod_jk2
+# Date created: Thu May 29 01:24:15 CEST 2003
+# Whom: Palle Girgensohn <girgen@pingpong.net>
#
# $FreeBSD$
#
-PORTNAME= mod_jk
-PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTNAME= mod_jk2
+PORTVERSION= 2.0.2
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
-MASTER_SITE_SUBDIR= jakarta-tomcat-connectors/jk/release/v${PORTVERSION}/src
-PKGNAMESUFFIX= -apache2
-DISTNAME= jakarta-tomcat-connectors-jk-${PORTVERSION}-src
+MASTER_SITE_SUBDIR= tomcat-connectors/jk2/source
+DISTNAME= jakarta-tomcat-connectors-jk2-${PORTVERSION}-src
-MAINTAINER= lansil@fuzzynerd.com
-COMMENT= Apache 2.0 module for Tomcat
+MAINTAINER= girgen@pingpong.net
+COMMENT= Apache JK2 module for connecting to Tomcat using AJP1X
USE_APACHE= yes
+USE_GMAKE= YES
+USE_LIBTOOL_VER= 13
+USE_AUTOCONF_VER= 253
+USE_AUTOMAKE_VER= 15
+AUTOMAKE_ARGS= --add-missing
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS+= --with-apxs${APACHE2}=${APXS}
+ALL_TARGET= jk2-build-apxs
+
+WRKSRC= ${WRKDIR}/jakarta-tomcat-connectors-jk2-${PORTVERSION}-src/jk/native2
+
+.include <bsd.port.pre.mk>
+
+.if exists(${LOCALBASE}/include/apache2/apr.h)
WITH_APACHE2= yes
-APACHE_CONF= ${PREFIX}/etc/apache2
-WRKSRC= ${WRKDIR}/jakarta-tomcat-connectors-jk-${PORTVERSION}-src/jk/native
+.endif
-USE_GMAKE= YES
-USE_LIBTOOL_VER=13
-USE_AUTOCONF_VER= 213
-USE_AUTOMAKE_VER= 14
-HAS_CONFIGURE= YES
-CONFIGURE_ARGS+= --with-apxs=${APXS}
+.if defined(WITH_APACHE2)
+APACHE2= 2
+PLIST_SUB= APACHE2=2
+PKGNAMESUFFIX= -apache2
+APACHE= apache2
+AP_EXT= la
+.else
+APACHE2=
+PLIST_SUB= APACHE2=
+AP_EXT= so
+APACHE= apache13
+.endif
+
+pre-patch: build-depends
+
+post-patch:
+ cd ${WRKSRC}; ${ACLOCAL}; ${LIBTOOLIZE}
do-install:
- ${APXS} -i -A -n jk ${WRKSRC}/apache-2.0/mod_jk.so
- ${SED} -e "s#%%APACHE_CONF%%#${APACHE_CONF}#g" ${FILESDIR}/mod_jk.conf.sample > ${WRKDIR}/mod_jk.conf.sample
- ${INSTALL_DATA} ${WRKDIR}/mod_jk.conf.sample ${APACHE_CONF}
- ${INSTALL_DATA} ${FILESDIR}/workers.properties.sample ${APACHE_CONF}
+ cd ${WRKSRC}/server/${APACHE} ;\
+ ${GMAKE} -f Makefile.apxs install ;\
+ ${APXS} -e -A -n jk2 mod_jk2.${AP_EXT}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>