aboutsummaryrefslogtreecommitdiff
path: root/www/mod_jk2/files
diff options
context:
space:
mode:
authorPalle Girgensohn <girgen@FreeBSD.org>2005-07-27 01:59:42 +0000
committerPalle Girgensohn <girgen@FreeBSD.org>2005-07-27 01:59:42 +0000
commit4efba361e649a33052f3704a63a93b5d12dfbc0a (patch)
tree1b25b660f33c6e450330b7f31a4b5822be7be6d0 /www/mod_jk2/files
parentfa6598a4165fb4f9f5e85675e831fd7129e7d629 (diff)
downloadports-4efba361e649a33052f3704a63a93b5d12dfbc0a.tar.gz
ports-4efba361e649a33052f3704a63a93b5d12dfbc0a.zip
Notes
Diffstat (limited to 'www/mod_jk2/files')
-rw-r--r--www/mod_jk2/files/patch-Makefile-in27
-rw-r--r--www/mod_jk2/files/patch-apache13-makefile-apxs-in14
-rw-r--r--www/mod_jk2/files/patch-common::jk_mutex_thread_c11
-rw-r--r--www/mod_jk2/files/patch-configure55
-rw-r--r--www/mod_jk2/files/patch-configure.in23
-rw-r--r--www/mod_jk2/files/patch-include::jk_mutex_h20
6 files changed, 82 insertions, 68 deletions
diff --git a/www/mod_jk2/files/patch-Makefile-in b/www/mod_jk2/files/patch-Makefile-in
new file mode 100644
index 000000000000..ac3dddb8e32a
--- /dev/null
+++ b/www/mod_jk2/files/patch-Makefile-in
@@ -0,0 +1,27 @@
+--- Makefile.in~ Wed Mar 24 14:33:15 2004
++++ Makefile.in Thu Sep 9 04:06:21 2004
+@@ -8,6 +8,8 @@
+
+ clean-apxs: @APR_CLEAN@ jk2-clean-apxs
+
++install: jk2-install
++
+ install-apxs: jk2-install-apxs
+
+ jk2-build:
+@@ -25,6 +27,15 @@
+ echo "Making $$target in $$i"; \
+ if test "$$i" != "."; then \
+ (cd $$i && $(MAKE) -f Makefile.apxs) || exit 1; \
++ fi; \
++ done;
++
++jk2-install:
++ list='@WEBSERVERS@'; \
++ for i in $$list; do \
++ echo "Making $$target in $$i"; \
++ if test "$$i" != "."; then \
++ (cd $$i && $(MAKE) install) || exit 1; \
+ fi; \
+ done;
+
diff --git a/www/mod_jk2/files/patch-apache13-makefile-apxs-in b/www/mod_jk2/files/patch-apache13-makefile-apxs-in
deleted file mode 100644
index 433e51d91e40..000000000000
--- a/www/mod_jk2/files/patch-apache13-makefile-apxs-in
+++ /dev/null
@@ -1,14 +0,0 @@
---- server/apache13/Makefile.apxs.in.orig Wed Mar 19 10:21:04 2003
-+++ server/apache13/Makefile.apxs.in Wed Jun 18 03:10:02 2003
-@@ -18,7 +18,10 @@
- all: mod_jk2.so
-
- mod_jk2.so:
-- $(APXS) -c -o $@ -Wc,"${JK_INCL} ${APR_CFLAGS} ${APR_LDFLAGS}" "${JAVA_INCL}" mod_jk2.c ${COMMON_C_FILES}
-+ $(APXS) -c -o $@ -Wc,"${JK_INCL} ${APR_CFLAGS} ${APR_LDFLAGS}" "${JAVA_INCL}" jk_service_apache13.c mod_jk2.c ${COMMON_C_FILES}
-+
-+install:
-+ $(APXS) -i mod_jk2.so
-
- clean:
- rm -f *.o *.so
diff --git a/www/mod_jk2/files/patch-common::jk_mutex_thread_c b/www/mod_jk2/files/patch-common::jk_mutex_thread_c
deleted file mode 100644
index 1021aa87df4a..000000000000
--- a/www/mod_jk2/files/patch-common::jk_mutex_thread_c
+++ /dev/null
@@ -1,11 +0,0 @@
---- common/jk_mutex_thread.c~ Thu Jul 31 19:30:38 2003
-+++ common/jk_mutex_thread.c Wed Sep 10 01:37:29 2003
-@@ -159,7 +159,7 @@
- }
-
-
--#elif defined( _REENTRANT )
-+#elif defined( _THREAD_SAFE ) && defined( FREEBSD_THREAD_HACK )
- /*-------------------- PThread - @deprecated, use APR if possible -------------------- */
-
- #include <pthread.h>
diff --git a/www/mod_jk2/files/patch-configure b/www/mod_jk2/files/patch-configure
new file mode 100644
index 000000000000..d0c98e7d9ba2
--- /dev/null
+++ b/www/mod_jk2/files/patch-configure
@@ -0,0 +1,55 @@
+--- configure.orig Wed Mar 24 14:46:12 2004
++++ configure Wed Jul 27 03:36:21 2005
+@@ -20237,15 +20231,15 @@
+
+ echo "$as_me:$LINENO: checking for apr APR_LIBNAME" >&5
+ echo $ECHO_N "checking for apr APR_LIBNAME... $ECHO_C" >&6
+- if ${TEST} ! -f "${APR_DIR}/apr-config" ; then
+- { { echo "$as_me:$LINENO: error: cannot find apr-config file in ${APR_DIR}" >&5
+-echo "$as_me: error: cannot find apr-config file in ${APR_DIR}" >&2;}
++ if ${TEST} ! -f "${APR_DIR}/apr-1-config" ; then
++ { { echo "$as_me:$LINENO: error: cannot find apr-1-config file in ${APR_DIR}" >&5
++echo "$as_me: error: cannot find apr-1-config file in ${APR_DIR}" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+- jk_apr_get_tempval=`${APR_DIR}/apr-config --link-libtool 2> /dev/null`
++ jk_apr_get_tempval=`${APR_DIR}/apr-1-config --link-libtool 2> /dev/null`
+ if ${TEST} -z "${jk_apr_get_tempval}" ; then
+- { { echo "$as_me:$LINENO: error: ${APR_DIR}/apr-config --link-libtool failed" >&5
+-echo "$as_me: error: ${APR_DIR}/apr-config --link-libtool failed" >&2;}
++ { { echo "$as_me:$LINENO: error: ${APR_DIR}/apr-1-config --link-libtool failed" >&5
++echo "$as_me: error: ${APR_DIR}/apr-1-config --link-libtool failed" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+ jk_apr_get_tempval=`basename ${jk_apr_get_tempval}`
+@@ -20384,15 +20378,15 @@
+
+ echo "$as_me:$LINENO: checking for apr-util APR_UTIL_LIBNAME" >&5
+ echo $ECHO_N "checking for apr-util APR_UTIL_LIBNAME... $ECHO_C" >&6
+- if ${TEST} ! -f "${APR_UTIL_DIR}/apu-config" ; then
+- { { echo "$as_me:$LINENO: error: cannot find apu-config file in ${APR_UTIL_DIR}" >&5
+-echo "$as_me: error: cannot find apu-config file in ${APR_UTIL_DIR}" >&2;}
++ if ${TEST} ! -f "${APR_UTIL_DIR}/apu-1-config" ; then
++ { { echo "$as_me:$LINENO: error: cannot find apu-1-config file in ${APR_UTIL_DIR}" >&5
++echo "$as_me: error: cannot find apu-1-config file in ${APR_UTIL_DIR}" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+- jk_apu_get_tempval=`${APR_UTIL_DIR}/apu-config --link-libtool 2> /dev/null`
++ jk_apu_get_tempval=`${APR_UTIL_DIR}/apu-1-config --link-libtool 2> /dev/null`
+ if ${TEST} -z "${jk_apu_get_tempval}" ; then
+- { { echo "$as_me:$LINENO: error: ${APR_UTIL_DIR}/apu-config --link-libtool failed" >&5
+-echo "$as_me: error: ${APR_UTIL_DIR}/apu-config --link-libtool failed" >&2;}
++ { { echo "$as_me:$LINENO: error: ${APR_UTIL_DIR}/apu-1-config --link-libtool failed" >&5
++echo "$as_me: error: ${APR_UTIL_DIR}/apu-1-config --link-libtool failed" >&2;}
+ { (exit 1); exit 1; }; }
+ fi
+ jk_apu_get_tempval=`basename ${jk_apu_get_tempval}`
+@@ -20490,7 +20484,7 @@
+ APR_CLEAN=""
+ APR_DIR=""
+ APR_LIBDIR=${tempval}
+- APR_LDFLAGS="`apr-config --link-ld` -L${tempval}"
++ APR_LDFLAGS="`apr-1-config --link-ld` -L${tempval}"
+ COMMON_APR_OBJECTS="\${COMMON_APR_OBJECTS}"
+ use_apr=true
+ fi
diff --git a/www/mod_jk2/files/patch-configure.in b/www/mod_jk2/files/patch-configure.in
deleted file mode 100644
index 7311ea55fdf1..000000000000
--- a/www/mod_jk2/files/patch-configure.in
+++ /dev/null
@@ -1,23 +0,0 @@
-The apache mod_jk modules *communicate* with Java using an internet
-protocol, AJP13, but they are written in C. I can't come up with any
-reason to look for a JDK here, it's plain stupid! Since apache and
-tomcat can be run on separate machines, there is no dependency
-whatsoever... /Palle
-
---- configure.in.orig Tue Oct 22 00:00:00 2002
-+++ configure.in Thu Feb 26 00:19:35 2004
-@@ -184,10 +184,10 @@
-
- dnl Java settings
-
--JK_JDK()
--JK_JDK_OS()
--JK_JNI()
--JK_PCRE()
-+dnl JK_JDK()
-+dnl JK_JDK_OS()
-+dnl JK_JNI()
-+dnl JK_PCRE()
-
- AC_SUBST(JAVA_HOME)
- AC_SUBST(JAVA_PLATFORM)
diff --git a/www/mod_jk2/files/patch-include::jk_mutex_h b/www/mod_jk2/files/patch-include::jk_mutex_h
deleted file mode 100644
index 0eea18125e22..000000000000
--- a/www/mod_jk2/files/patch-include::jk_mutex_h
+++ /dev/null
@@ -1,20 +0,0 @@
---- include/jk_mutex.h~ Thu Jul 31 19:30:40 2003
-+++ include/jk_mutex.h Wed Sep 10 01:33:27 2003
-@@ -76,7 +76,7 @@
- #include "apr_thread_mutex.h"
- #elif defined( WIN32 )
- #include <windows.h>
--#elif defined( _REENTRANT )
-+#elif defined( _THREAD_SAFE ) && defined ( FREEBSD_THREAD_HACK )
- #include <pthread.h>
- #endif
-
-@@ -122,7 +122,7 @@
- apr_thread_mutex_t *threadMutex;
- #elif defined( WIN32 )
- CRITICAL_SECTION threadMutex;
--#elif defined( _REENTRANT )
-+#elif defined( _THREAD_SAFE ) && defined ( FREEBSD_THREAD_HACK )
- pthread_mutex_t threadMutex;
- #else
- void *threadMutex;