aboutsummaryrefslogtreecommitdiff
path: root/www/mod_log_data
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-02-26 16:42:03 +0000
committerClement Laforet <clement@FreeBSD.org>2004-02-26 16:42:03 +0000
commitdc5eb9e2d509b5a075bb0ad25bc2496d15f22670 (patch)
treed63f0b0548a0f8917d9be58845c6afec49d997b7 /www/mod_log_data
parent4094dc43bf49dc295a6f724ab8f5c376b5b19535 (diff)
downloadports-dc5eb9e2d509b5a075bb0ad25bc2496d15f22670.tar.gz
ports-dc5eb9e2d509b5a075bb0ad25bc2496d15f22670.zip
Notes
Diffstat (limited to 'www/mod_log_data')
-rw-r--r--www/mod_log_data/Makefile33
-rw-r--r--www/mod_log_data/distinfo1
-rw-r--r--www/mod_log_data/pkg-descr7
-rw-r--r--www/mod_log_data/pkg-plist4
4 files changed, 45 insertions, 0 deletions
diff --git a/www/mod_log_data/Makefile b/www/mod_log_data/Makefile
new file mode 100644
index 000000000000..b8f87d6b1599
--- /dev/null
+++ b/www/mod_log_data/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: mod_log_data
+# Date created: Sun Oct 5
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_log_data
+PORTVERSION= 0.0.3
+CATEGORIES= www
+MASTER_SITES= http://loghttp.sourceforge.net/files/
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Module for Apache 2.0 to log incoming and outgoing data
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+USE_APACHE= YES
+WITH_APACHE2= YES
+
+.include <bsd.port.pre.mk>
+
+ONLY_FOR_ARCHS= i386
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.la)
+
+.include <bsd.port.post.mk>
diff --git a/www/mod_log_data/distinfo b/www/mod_log_data/distinfo
new file mode 100644
index 000000000000..a333746a2edd
--- /dev/null
+++ b/www/mod_log_data/distinfo
@@ -0,0 +1 @@
+MD5 (mod_log_data-0.0.3.tar.gz) = 473a72701cf1db6671a114f086f60af1
diff --git a/www/mod_log_data/pkg-descr b/www/mod_log_data/pkg-descr
new file mode 100644
index 000000000000..1d11734e16c6
--- /dev/null
+++ b/www/mod_log_data/pkg-descr
@@ -0,0 +1,7 @@
+mod_log_data is a module for Apache 2.0, logging incoming and outgoing
+data.
+This module can be used for debug or for security.
+This beta version include one filter dumping the POST data for an
+incoming request, and a filter dumping the outgoing data.
+
+WWW: http://loghttp.sourceforge.net/
diff --git a/www/mod_log_data/pkg-plist b/www/mod_log_data/pkg-plist
new file mode 100644
index 000000000000..1222ccc92160
--- /dev/null
+++ b/www/mod_log_data/pkg-plist
@@ -0,0 +1,4 @@
+libexec/apache2/mod_log_data.so
+@exec %D/sbin/apxs -e -a -n log_data %D/%f
+@unexec %D/sbin/apxs -e -a -n log_data %D/%f
+@unexec echo "===> If you do not plan on reinstalling mod_log_data, you must manually remove"; echo "===> references to it in httpd.conf."