aboutsummaryrefslogtreecommitdiff
path: root/www/mod_log_spread
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-14 11:07:08 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-05-14 11:07:08 +0000
commit93eac884d93e57c151c8a6b63c9a5a06f0bfb442 (patch)
tree0893704bb803bb0d192708a68402e57e2de36093 /www/mod_log_spread
parent0a2ac039877c7c084839ea73423932e0a9fe7a44 (diff)
Notes
Diffstat (limited to 'www/mod_log_spread')
-rw-r--r--www/mod_log_spread/Makefile40
-rw-r--r--www/mod_log_spread/distinfo2
-rw-r--r--www/mod_log_spread/files/patch-mod_log_spread.c11
-rw-r--r--www/mod_log_spread/pkg-descr14
-rw-r--r--www/mod_log_spread/pkg-plist3
5 files changed, 70 insertions, 0 deletions
diff --git a/www/mod_log_spread/Makefile b/www/mod_log_spread/Makefile
new file mode 100644
index 000000000000..d87dcec00607
--- /dev/null
+++ b/www/mod_log_spread/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: mod_log_spread
+# Date created: 08 May 2005
+# Whom: Meno Abels <meno.abels@adviser.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_log_spread
+PORTVERSION= 1.0.4
+CATEGORIES= www net
+MASTER_SITES= http://www.lethargy.org/mod_log_spread/
+
+MAINTAINER= meno.abels@adviser.com
+COMMENT= An Apache module interfacing with spread
+
+LIB_DEPENDS= spread.1:${PORTSDIR}/net/spread
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_APACHE= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= CHANGELOG INSTALL LICENSE README README.spread \
+ error_log_spread.pl sample_configurations.txt \
+ spreadlogd.README spread.html
+.endif
+
+do-build:
+ cd ${WRKSRC} && ${APXS} -I${PREFIX}/include -c mod_log_spread.c
+
+do-install:
+ ${APXS} -i -a -n log_spread ${WRKSRC}/mod_log_spread.so
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_log_spread/distinfo b/www/mod_log_spread/distinfo
new file mode 100644
index 000000000000..17719d852662
--- /dev/null
+++ b/www/mod_log_spread/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_log_spread-1.0.4.tar.gz) = 2833402e15fcb05d6d493200157635ba
+SIZE (mod_log_spread-1.0.4.tar.gz) = 26984
diff --git a/www/mod_log_spread/files/patch-mod_log_spread.c b/www/mod_log_spread/files/patch-mod_log_spread.c
new file mode 100644
index 000000000000..863f54f56347
--- /dev/null
+++ b/www/mod_log_spread/files/patch-mod_log_spread.c
@@ -0,0 +1,11 @@
+--- mod_log_spread.c.orig Thu Aug 16 04:27:58 2001
++++ mod_log_spread.c Wed May 11 06:55:14 2005
+@@ -895,7 +895,7 @@
+ static int spread_multicast_log_to_daemon(request_rec *r, char *group_name, int daemon_index, char *str, int len)
+ {
+ int sperror;
+- char *src;
++ const char *src;
+ char tmpgrp[MAX_GROUP_NAME];
+ char lchostname[1024];
+ char *dst = lchostname;
diff --git a/www/mod_log_spread/pkg-descr b/www/mod_log_spread/pkg-descr
new file mode 100644
index 000000000000..e9e5168f7602
--- /dev/null
+++ b/www/mod_log_spread/pkg-descr
@@ -0,0 +1,14 @@
+mod_log_spread is a patch to Apache's mod_log_config, which provides
+an interface for spread to multicast access logs. It utilizes the
+group communication toolkit Spread, developed at Johns Hopkins
+University's Center for Networking and Distributed Systems.
+mod_log_spread was developed to solve the problem of collecting
+consolidated access logs for large web farms. In particular, the
+solution needed to be scalable to hundreds of machines, utilize a
+reliable network transport, allow machines to added or dropped on
+the fly, and impose minimal performance impact on the webservers.
+Current version is 1.0.3p3. This makes a fix to a stupid vhost
+logging bug as well as providing a complete and flexible log-writing
+solution.
+
+WWW: http://www.lethargy.org/mod_log_spread/
diff --git a/www/mod_log_spread/pkg-plist b/www/mod_log_spread/pkg-plist
new file mode 100644
index 000000000000..899c252fcc60
--- /dev/null
+++ b/www/mod_log_spread/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache/mod_log_spread.so
+@exec %D/sbin/apxs -e -a -n log_spread %D/%F
+@unexec %D/sbin/apxs -e -A -n log_spread %D/%F