aboutsummaryrefslogtreecommitdiff
path: root/www/mod_log_sql2-dtc/Makefile
diff options
context:
space:
mode:
authorMarc G. Fournier <scrappy@FreeBSD.org>2006-11-20 06:13:45 +0000
committerMarc G. Fournier <scrappy@FreeBSD.org>2006-11-20 06:13:45 +0000
commit15e3e326f48b83c188937e888428ed4d4692c8b6 (patch)
tree2f65451f6967a2ffb68645d493d0013019ed20bf /www/mod_log_sql2-dtc/Makefile
parentd830a9266bc5bb3fb719f02a0c2288f58d2606b9 (diff)
Notes
Diffstat (limited to 'www/mod_log_sql2-dtc/Makefile')
-rw-r--r--www/mod_log_sql2-dtc/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/www/mod_log_sql2-dtc/Makefile b/www/mod_log_sql2-dtc/Makefile
new file mode 100644
index 000000000000..b0f5aaca7989
--- /dev/null
+++ b/www/mod_log_sql2-dtc/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: mod_log_sql2-dtc
+# Date created: 2006/11/20
+# Whom: Marc G. Fournier <scrappy@freebsd.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_log_sql
+PORTVERSION= 1.100
+CATEGORIES= www databases
+MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
+
+MAINTAINER= scrappy@freebsd.org
+COMMENT= Allows Apache to log to a MySQL database
+
+LATEST_LINK= mod_log_sql2
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+SSL_PLIST= ""
+PLIST_SUB+= SSL=${SSL_PLIST}
+
+USE_MYSQL= yes
+CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
+
+.include <bsd.port.pre.mk>
+.if defined(WITH_DBI) || exists(${LOCALBASE}/include/dbi/dbi.h)
+CONFIGURE_ARGS+= --with-dbi=${LOCALBASE}
+LIB_DEPENDS+= dbi.0:${PORTSDIR}/databases/libdbi
+.endif
+.include "${PORTSDIR}/www/apache20/Makefile.modules.3rd"
+. if ${AP_VER} == 13
+WITHOUT_SSL= YES
+. endif
+.if defined(WITHOUT_SSL)
+CONFIGURE_ARGS+= --disable-ssl
+SSL_PLIST= "@comment "
+.else
+.if !exists(${LOCALBASE}/include/apache2/mod_ssl.h)
+BROKEN= Please recompile apache2 with SSL support
+.endif
+.endif
+
+.include <bsd.port.post.mk>