aboutsummaryrefslogtreecommitdiff
path: root/www/mod_log_sql2/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2014-03-02 21:51:34 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2014-03-02 21:51:34 +0000
commitb4251833a4bb33a04a71a77204efbf8e5824937e (patch)
treee9c2b953de1d9b132f32a321eab1503679fed545 /www/mod_log_sql2/Makefile
parentaeb6636cb39108577453de5c7bd714912d875eed (diff)
downloadports-b4251833a4bb33a04a71a77204efbf8e5824937e.tar.gz
ports-b4251833a4bb33a04a71a77204efbf8e5824937e.zip
Notes
Diffstat (limited to 'www/mod_log_sql2/Makefile')
-rw-r--r--www/mod_log_sql2/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/www/mod_log_sql2/Makefile b/www/mod_log_sql2/Makefile
index 73291836ef47..4397f13c183c 100644
--- a/www/mod_log_sql2/Makefile
+++ b/www/mod_log_sql2/Makefile
@@ -11,7 +11,6 @@ PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows Apache to log to a MySQL database
-
LATEST_LINK= mod_log_sql2
GNU_CONFIGURE= yes
USE_BZIP2= yes
@@ -29,7 +28,7 @@ CONFIGURE_ENV+= LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/lib/mysql"
.if defined(WITH_DBI) || exists(${LOCALBASE}/include/dbi/dbi.h)
CONFIGURE_ARGS+= --with-dbi=${LOCALBASE}
-LIB_DEPENDS+= dbi.1:${PORTSDIR}/databases/libdbi
+LIB_DEPENDS+= libdbi.so:${PORTSDIR}/databases/libdbi
.endif
.if defined(WITHOUT_SSL)
@@ -37,7 +36,11 @@ CONFIGURE_ARGS+= --disable-ssl
SSL_PLIST= "@comment "
.endif
-post-install:
- @${APXS} -e -a -n "${SHORTMODNAME}" "${STAGEDIR}${APACHEMODDIR}/${MODULENAME}.so"
+post-patch:
+ ${REINPLACE_CMD} -e 's|@APXS_STAGE@|-S LIBEXECDIR=${STAGEDIR}${PREFIX}/${APACHEMODDIR}|' \
+ ${WRKSRC}/Makefile.in
+
+pre-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}
.include <bsd.port.post.mk>