aboutsummaryrefslogtreecommitdiff
path: root/www/mod_log_sql2
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-16 19:57:21 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-16 19:57:21 +0000
commit52fc6525910b1699dc2c025709783c4a900546c9 (patch)
tree130333058e0bc60cfe820465ce907c44dc9bd98a /www/mod_log_sql2
parenta06290b8cf792d259c7743a91954114c87ddbe4d (diff)
downloadports-52fc6525910b1699dc2c025709783c4a900546c9.tar.gz
ports-52fc6525910b1699dc2c025709783c4a900546c9.zip
Notes
Diffstat (limited to 'www/mod_log_sql2')
-rw-r--r--www/mod_log_sql2/Makefile35
-rw-r--r--www/mod_log_sql2/distinfo2
-rw-r--r--www/mod_log_sql2/files/patch-functions13.h11
-rw-r--r--www/mod_log_sql2/files/patch-mod_log_sql.c31
-rw-r--r--www/mod_log_sql2/pkg-descr4
-rw-r--r--www/mod_log_sql2/pkg-plist6
6 files changed, 89 insertions, 0 deletions
diff --git a/www/mod_log_sql2/Makefile b/www/mod_log_sql2/Makefile
new file mode 100644
index 000000000000..150fcf9fb74c
--- /dev/null
+++ b/www/mod_log_sql2/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: mod_log_sql2
+# Date created: 2001/11/22
+# Whom: Clement Laforet <clement@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_log_sql
+PORTVERSION= 1.97
+CATEGORIES= www databases
+MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Allows Apache to log to a MySQL database
+
+GNU_CONFIGURE= yes
+USE_MYSQL= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+SSL_PLIST= "@comment "
+PLIST_SUB+= SSL=${SSL_PLIST}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+.if defined(WITH_SSL)
+. if ${AP_VER} != 2
+BROKEN= "SSL support needs apache2"
+. endif
+.if !exists(${LOCALBASE}/include/apache2/mod_ssl.h)
+BROKEN= "Please recompile apache2 with SSL support"
+.endif
+CONFIGURE_ARGS+= --enable-ssl
+SSL_PLIST= ""
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/mod_log_sql2/distinfo b/www/mod_log_sql2/distinfo
new file mode 100644
index 000000000000..9a6896179eab
--- /dev/null
+++ b/www/mod_log_sql2/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_log_sql-1.97.tar.gz) = 6e5616dbb6eec5e1acd2d3fd8b42e5be
+SIZE (mod_log_sql-1.97.tar.gz) = 148593
diff --git a/www/mod_log_sql2/files/patch-functions13.h b/www/mod_log_sql2/files/patch-functions13.h
new file mode 100644
index 000000000000..4fda5d4d58bc
--- /dev/null
+++ b/www/mod_log_sql2/files/patch-functions13.h
@@ -0,0 +1,11 @@
+--- functions13.h.orig Fri Apr 16 15:03:25 2004
++++ functions13.h Fri Apr 16 15:03:46 2004
+@@ -37,7 +37,7 @@
+
+ static const char *extract_request_duration(request_rec *r, char *a)
+ {
+- return ap_psprintf(r->pool, "%ld", time(NULL) - r->request_time);
++ return ap_psprintf(r->pool, "%ld", (long)time(NULL) - r->request_time);
+ }
+
+ static const char *extract_request_timestamp(request_rec *r, char *a)
diff --git a/www/mod_log_sql2/files/patch-mod_log_sql.c b/www/mod_log_sql2/files/patch-mod_log_sql.c
new file mode 100644
index 000000000000..4b58535863f1
--- /dev/null
+++ b/www/mod_log_sql2/files/patch-mod_log_sql.c
@@ -0,0 +1,31 @@
+--- mod_log_sql.c.orig Fri Apr 16 14:47:38 2004
++++ mod_log_sql.c Fri Apr 16 14:47:51 2004
+@@ -1,5 +1,13 @@
+ /* $Id: mod_log_sql.c,v 1.20 2004/03/05 00:30:58 urkle Exp $ */
+
++#if defined(WITH_APACHE20)
++# include "apache20.h"
++#elif defined(WITH_APACHE13)
++# include "apache13.h"
++#else
++# error Unsupported Apache version
++#endif
++
+ #ifdef HAVE_CONFIG_H
+ /* Undefine these to prevent conflicts between Apache ap_config_auto.h and
+ * my config.h. Only really needed for Apache < 2.0.48, but it can't hurt.
+@@ -11,14 +19,6 @@
+ #undef PACKAGE_VERSION
+
+ #include "config.h"
+-#endif
+-
+-#if defined(WITH_APACHE20)
+-# include "apache20.h"
+-#elif defined(WITH_APACHE13)
+-# include "apache13.h"
+-#else
+-# error Unsupported Apache version
+ #endif
+
+ #if APR_HAVE_UNISTD_H
diff --git a/www/mod_log_sql2/pkg-descr b/www/mod_log_sql2/pkg-descr
new file mode 100644
index 000000000000..cb25b6d20072
--- /dev/null
+++ b/www/mod_log_sql2/pkg-descr
@@ -0,0 +1,4 @@
+This add-on module allows the apache web server to use a MySQL database for
+logging of all operations.
+
+WWW: http://www.outoforder.cc/projects/apache/mod_log_sql/
diff --git a/www/mod_log_sql2/pkg-plist b/www/mod_log_sql2/pkg-plist
new file mode 100644
index 000000000000..bf25e78467fd
--- /dev/null
+++ b/www/mod_log_sql2/pkg-plist
@@ -0,0 +1,6 @@
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+%%APACHEMODDIR%%/mod_log_sql_mysql.so
+%%SSL%%%%APACHEMODDIR%%/mod_log_sql_ssl.so
+