aboutsummaryrefslogtreecommitdiff
path: root/www/mod_musicindex/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-01-17 21:15:10 +0000
committerClement Laforet <clement@FreeBSD.org>2005-01-17 21:15:10 +0000
commitea30aefdf1119562950d44039c1f31e8c6947f8f (patch)
tree785939ce0d09419fbd36a689e3fb71bf69b4d262 /www/mod_musicindex/Makefile
parent7030801ba5f5449a5b34437ed3760957f4963770 (diff)
Notes
Diffstat (limited to 'www/mod_musicindex/Makefile')
-rw-r--r--www/mod_musicindex/Makefile53
1 files changed, 19 insertions, 34 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 0906ae29524a..5125cc6a0c7b 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -6,53 +6,38 @@
#
PORTNAME= mod_musicindex
-PORTVERSION= 0.9.0
-PORTREVISION= 3
+PORTVERSION= 0.99.7
CATEGORIES= www audio
-MASTER_SITES= http://www.esiee.fr/~puffin/musicindex/
+# Master site don't have a current version'd tarball...
+#MASTER_SITES= http://www.esiee.fr/~puffin/musicindex/
+MASTER_SITES= http://sheepkiller.nerim.net/
DISTNAME= libapache-mod-musicindex_${PORTVERSION}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module in C implements Perl module Apache::MP3
-BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-RUN_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT}
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
id3tag.2:${PORTSDIR}/audio/libid3tag \
- mad.2:${PORTSDIR}/audio/libmad
+ mad.2:${PORTSDIR}/audio/libmad \
+ FLAC.5:${PORTSDIR}/audio/flac
-APXS?= ${LOCALBASE}/sbin/apxs
+CPPFLAGS= -DHAS_MP3 -DHAS_OGG -DHAS_FLAC
+CFLAGS+= -I${LOCALBASE}/include
+
+#WANT_APACHE= YES
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/libapache-mod-musicindex-${PORTVERSION}
-MAKE_ENV+= APXS=${APXS} BUILDDIR=${WRKSRC}
PORTDOCS= directory.png musicindex.css fetch.png \
- right_arrow.gif general.png sound.png
-
-.if defined (WITH_APACHE2)
-MODULE_EXT= la
-MAKEFILE= Makefile.apache2
-PLIST_SUB+= MOD_DIR=libexec/apache2
-APACHE_PORT?= www/apache2
-MAKE_TARGET= all
-.else
-MODULE_EXT= so
-PLIST_SUB+= MOD_DIR=libexec/apache
-APACHE_PORT?= www/apache13
-.endif
+ right_arrow.gif general.png sound.png
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/www/apache2/Makefile.modules.3rd"
+
+MAKE_ENV+= APXS=${APXS} CPPFLAGS="${CPPFLAGS}" LDFLAGS="-L${LOCALBASE}/lib"
-post-patch:
- @${CP} ${WRKSRC}/modules.mk.apache2 ${WRKSRC}/modules.mk
- @${TOUCH} ${WRKSRC}/.deps
-
-do-install:
- ${APXS} -i -n musicindex -A ${WRKSRC}/mod_musicindex.${MODULE_EXT}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/musicindex/${f} ${DOCSDIR}
-.endfor
+.if "${AP_VER}"=="2"
+MAKE_ENV+= APACHE_VERSION=2 APRCONFIG=${LOCALBASE}/lib/apache2/apr-config
.endif
- ${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>