aboutsummaryrefslogtreecommitdiff
path: root/www/mod_musicindex/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-11 05:20:35 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-11-11 05:20:35 +0000
commit84a12a13b7fe2b532a4d6bd24432f320173379ce (patch)
tree40858e2552d339d32474ddac1d00b4ada8c63a4c /www/mod_musicindex/Makefile
parent73bd439e3ef5507cabbdfb2a096d0df98cbb2501 (diff)
downloadports-84a12a13b7fe2b532a4d6bd24432f320173379ce.tar.gz
ports-84a12a13b7fe2b532a4d6bd24432f320173379ce.zip
Notes
Diffstat (limited to 'www/mod_musicindex/Makefile')
-rw-r--r--www/mod_musicindex/Makefile37
1 files changed, 30 insertions, 7 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 1211b8ee3fe6..d9555e900462 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -6,22 +6,24 @@
#
PORTNAME= mod_musicindex
-PORTVERSION= 1.3.3
-PORTREVISION= 4
+PORTVERSION= 1.3.5
CATEGORIES= www audio
-MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/oldsrc/
+MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module that allows downloading and streaming of audio
+LICENSE= LGPL21
+
OPTIONS= NLS "Native language support" on \
FLAC "FLAC support" off \
MP3 "MP3 support" on \
MP4 "MP4 support" off \
VORBIS "Ogg/Vorbis support" off \
LIBARCHIVE "Archive downloading support" on \
- FILECACHE "Caching support" on
+ FILECACHE "Flat file caching support" on \
+ MYSQLCACHE "MySQL caching support" off
MAKE_JOBS_SAFE= yes
@@ -29,7 +31,8 @@ USE_APACHE= 2.0+
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --with-apxs=${APXS}
+CONFIGURE_ARGS= --with-apxs=${APXS} \
+ --disable-libFLACtest --disable-vorbistest
SUB_FILES= pkg-message
SUB_LIST= PORTNAME=${PORTNAME}
@@ -39,7 +42,7 @@ PORTDOCS= README
.include <bsd.port.options.mk>
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
@@ -54,7 +57,7 @@ LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
.endif
.if defined(WITHOUT_MP3)
-CONFIGURE_ARGS+=--disable-mp3
+CONFIGURE_ARGS+= --disable-mp3
.else
LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag \
mad:${PORTSDIR}/audio/libmad
@@ -80,6 +83,26 @@ CONFIGURE_ARGS+= --disable-archive
CONFIGURE_ARGS+= --disable-filecache
.endif
+.if defined(WITHOUT_MYSQLCACHE)
+CONFIGURE_ARGS+= --disable-mysqlcache
+.else
+USE_MYSQL= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/@BUILD_FOR_APACHE2/ s| -i -n musicindex| -a &|' \
+ ${WRKSRC}/src/Makefile.in
+.if !defined(WITHOUT_NLS)
+ ${RM} ${WRKSRC}/po/*.gmo
+ ${MV} ${WRKSRC}/po/pt-br.po ${WRKSRC}/po/pt_BR.po
+ cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|pt-br|pt_BR|g' ${WRKSRC}/po/LINGUAS ${WRKSRC}/po/pt_BR.po
+.endif
+
+post-build:
+.if !defined(WITHOUT_NLS)
+ cd ${WRKSRC}/po && ${SETENV} ${MAKE_ENV} ${MAKE} update-gmo
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}/