aboutsummaryrefslogtreecommitdiff
path: root/www/mod_musicindex/Makefile
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-08-12 12:50:26 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-08-12 12:50:26 +0000
commitd122b73de24a4e8919b200626e7f1b4bb34fbc0c (patch)
treeb3e7e6c79e008f074e4799aad369499424aad704 /www/mod_musicindex/Makefile
parent43b63893be8b4e9299ce9bf95aaef959a4f586e2 (diff)
- Update to 1.2.0
PR: ports/115280 Submitted by: Tobias Roth <ports at fsck.ch> (maintainer)
Notes
Notes: svn path=/head/; revision=197521
Diffstat (limited to 'www/mod_musicindex/Makefile')
-rw-r--r--www/mod_musicindex/Makefile78
1 files changed, 55 insertions, 23 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index c790089bc67a..ad0747f88d9d 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -6,40 +6,72 @@
#
PORTNAME= mod_musicindex
-PORTVERSION= 0.99.7
-PORTREVISION= 4
+PORTVERSION= 1.2.0
CATEGORIES= www audio
-# Master site doesn't have a current version'd tarball...
-#MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/
-MASTER_SITES= http://depot.fsck.ch/mirror/distfiles/
-DISTNAME= libapache-mod-musicindex_${PORTVERSION}
+MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/ \
+ http://depot.fsck.ch/mirror/distfiles/
MAINTAINER= ports@fsck.ch
-COMMENT= Apache module in C that implements the perl module Apache::MP3
+COMMENT= Apache module that allows downloading and streaming of audio
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- id3tag.0:${PORTSDIR}/audio/libid3tag \
- mad.2:${PORTSDIR}/audio/libmad \
- FLAC.7:${PORTSDIR}/audio/flac
+OPTIONS= NLS "Native language support" on \
+ FLAC "FLAC support" off \
+ MP3 "MP3 support" on \
+ MP4 "MP4 support" off \
+ VORBIS "Ogg/Vorbis support" off \
+ LIBARCHIVE "Archive downloading support" on \
+ FILECACHE "Caching support" on
-CPPFLAGS= -DHAS_MP3 -DHAS_OGG -DHAS_FLAC
-CFLAGS+= -I${LOCALBASE}/include
-
-#WANT_APACHE= YES
-USE_GMAKE= yes
-WRKSRC= ${WRKDIR}/libapache-mod-musicindex-${PORTVERSION}
+USE_APACHE= 1.3+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+PORTDOCS= README
SUB_FILES= pkg-message
+SUB_LIST= PORTNAME=${PORTNAME}
.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/www/apache20/Makefile.modules.3rd"
-MAKE_ENV+= APXS=${APXS} CPPFLAGS="${CPPFLAGS}" LDFLAGS="-L${LOCALBASE}/lib"
+.if defined(WITHOUT_NLS)
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.else
+USE_GETTEXT= yes
+CFLAGS+= -lintl
+PLIST_SUB+= NLS=""
+.endif
+
+.if defined(WITHOUT_FLAC)
+CONFIGURE_ARGS+= --disable-flac
+.else
+LIB_DEPENDS+= FLAC:${PORTSDIR}/audio/flac
+.endif
+
+.if defined(WITHOUT_MP3)
+CONFIGURE_ARGS+=--disable-mp3
+.else
+LIB_DEPENDS+= id3tag:${PORTSDIR}/audio/libid3tag \
+ mad:${PORTSDIR}/audio/libmad
+.endif
-.if "${AP_VER}"=="2"
-MAKE_ENV+= APACHE_VERSION=2 APRCONFIG=${LOCALBASE}/lib/apache2/apr-config
-.if "ARCH" = "amd64"
-CFLAGS+= -fPIC
+.if defined(WITHOUT_MP4)
+CONFIGURE_ARGS+= --disable-mp4
+.else
+LIB_DEPENDS+= mp4v2:${PORTSDIR}/multimedia/mpeg4ip-libmp4v2
.endif
+
+.if defined(WITHOUT_VORBIS)
+CONFIGURE_ARGS+= --disable-vorbis
+.else
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
+.endif
+
+.if defined(WITHOUT_LIBARCHIVE)
+CONFIGURE_ARGS+= --disable-archive
+.endif
+
+.if defined(WITHOUT_FILECACHE)
+CONFIGURE_ARGS+= --disable-filecache
.endif
post-install: