aboutsummaryrefslogtreecommitdiff
path: root/www/mod_musicindex/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-01-22 20:56:55 +0000
committerClement Laforet <clement@FreeBSD.org>2005-01-22 20:56:55 +0000
commit326013b043a900a3bb65ff32f6a600e734d8cccd (patch)
treeb203411f31ff7d28e743ab02a1aa3a2a0b508bd2 /www/mod_musicindex/Makefile
parent1953b245625052cdd6930713d1adac08a8abc1ab (diff)
Notes
Diffstat (limited to 'www/mod_musicindex/Makefile')
-rw-r--r--www/mod_musicindex/Makefile21
1 files changed, 16 insertions, 5 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 5125cc6a0c7b..abb376ea820c 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -7,14 +7,15 @@
PORTNAME= mod_musicindex
PORTVERSION= 0.99.7
+PORTREVISION= 1
CATEGORIES= www audio
-# Master site don't have a current version'd tarball...
-#MASTER_SITES= http://www.esiee.fr/~puffin/musicindex/
-MASTER_SITES= http://sheepkiller.nerim.net/
+# Master site doesn't have a current version'd tarball...
+#MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/
+MASTER_SITES= http://depot.fsck.ch/mirror/distfiles/
DISTNAME= libapache-mod-musicindex_${PORTVERSION}
-MAINTAINER= apache@FreeBSD.org
-COMMENT= Apache module in C implements Perl module Apache::MP3
+MAINTAINER= ports@fsck.ch
+COMMENT= Apache module in C that implements the perl module Apache::MP3
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
id3tag.2:${PORTSDIR}/audio/libid3tag \
@@ -27,6 +28,7 @@ CFLAGS+= -I${LOCALBASE}/include
#WANT_APACHE= YES
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/libapache-mod-musicindex-${PORTVERSION}
+SUB_FILES= pkg-message
PORTDOCS= directory.png musicindex.css fetch.png \
right_arrow.gif general.png sound.png
@@ -40,4 +42,13 @@ MAKE_ENV+= APXS=${APXS} CPPFLAGS="${CPPFLAGS}" LDFLAGS="-L${LOCALBASE}/lib"
MAKE_ENV+= APACHE_VERSION=2 APRCONFIG=${LOCALBASE}/lib/apache2/apr-config
.endif
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ @${ECHO_MSG} ""
+ @${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG} ""
+
.include <bsd.port.post.mk>