aboutsummaryrefslogtreecommitdiff
path: root/www/mod_musicindex
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-03 16:17:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-11-03 16:17:10 +0000
commit9c118d4f8e2ec05cd157aac1e3031412910acefc (patch)
tree707dd7b03b9a853ad0bbd6c87b2f2662522df719 /www/mod_musicindex
parentc0e738018d8914cc51550e4dbf3eb736b46cad99 (diff)
downloadports-9c118d4f8e2ec05cd157aac1e3031412910acefc.tar.gz
ports-9c118d4f8e2ec05cd157aac1e3031412910acefc.zip
Notes
Diffstat (limited to 'www/mod_musicindex')
-rw-r--r--www/mod_musicindex/Makefile42
-rw-r--r--www/mod_musicindex/distinfo1
-rw-r--r--www/mod_musicindex/files/patch-Makefile13
-rw-r--r--www/mod_musicindex/files/patch-playlist.h10
-rw-r--r--www/mod_musicindex/pkg-descr6
-rw-r--r--www/mod_musicindex/pkg-message26
-rw-r--r--www/mod_musicindex/pkg-plist10
7 files changed, 108 insertions, 0 deletions
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
new file mode 100644
index 000000000000..50d5c2c9e29c
--- /dev/null
+++ b/www/mod_musicindex/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: mod_musicindex
+# Date created: Nov 1 2003
+# Whom: clsung
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_musicindex
+PORTVERSION= 0.8.9
+CATEGORIES= www audio
+MASTER_SITES= http://www.esiee.fr/~puffin/musicindex/
+DISTNAME= libapache-mod-musicindex_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Apache module in C implements Perl module Apache::MP3
+
+BUILD_DEPENDS= ${APXS}:${APACHE_PORT}
+RUN_DEPENDS= ${APXS}:${APACHE_PORT}
+LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
+ vorbis.2:${PORTSDIR}/audio/libvorbis \
+ id3tag.1:${PORTSDIR}/audio/mad \
+ mad.1:${PORTSDIR}/audio/mad
+
+APXS?= ${LOCALBASE}/sbin/apxs
+APACHE_PORT?= ${PORTSDIR}/www/apache13
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/libapache-mod-musicindex-${PORTVERSION}
+
+DOCS_HTMLIMAGES= directory.png musicindex.css fetch.png \
+ right_arrow.gif general.png sound.png
+
+do-install:
+ ${APXS} -i -A -n musicindex ${WRKSRC}/mod_musicindex.so
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for f in ${DOCS_HTMLIMAGES}
+ ${INSTALL_DATA} ${WRKSRC}/musicindex/${f} ${DOCSDIR}
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/www/mod_musicindex/distinfo b/www/mod_musicindex/distinfo
new file mode 100644
index 000000000000..97a394aa0d69
--- /dev/null
+++ b/www/mod_musicindex/distinfo
@@ -0,0 +1 @@
+MD5 (libapache-mod-musicindex_0.8.9.tar.gz) = 49eede2e4935f32b7f5f60a4782aa9a0
diff --git a/www/mod_musicindex/files/patch-Makefile b/www/mod_musicindex/files/patch-Makefile
new file mode 100644
index 000000000000..beac1087907e
--- /dev/null
+++ b/www/mod_musicindex/files/patch-Makefile
@@ -0,0 +1,13 @@
+--- Makefile.orig Thu Oct 30 20:41:45 2003
++++ Makefile Tue Nov 4 00:03:52 2003
+@@ -15,8 +15,8 @@
+
+ # additional user defines, includes and libraries
+ #DEF =
+-#INC =
+-#LIB =
++INC = -I/usr/local/include
++LIB = -L/usr/local/lib
+ CFLAGS = -O2 -Wall
+ DOCROOT = /var/www
+
diff --git a/www/mod_musicindex/files/patch-playlist.h b/www/mod_musicindex/files/patch-playlist.h
new file mode 100644
index 000000000000..3f780db1a915
--- /dev/null
+++ b/www/mod_musicindex/files/patch-playlist.h
@@ -0,0 +1,10 @@
+--- playlist.h.orig Thu Oct 30 20:41:45 2003
++++ playlist.h Tue Nov 4 00:03:01 2003
+@@ -51,5 +51,7 @@
+
+ mu_ent *new_ent(apr_pool_t *pool, mu_ent *head);
+
++#define FALSE 0
++#define TRUE !FALSE
+
+ #endif
diff --git a/www/mod_musicindex/pkg-descr b/www/mod_musicindex/pkg-descr
new file mode 100644
index 000000000000..7fa3617468d2
--- /dev/null
+++ b/www/mod_musicindex/pkg-descr
@@ -0,0 +1,6 @@
+mod_musicindex is an Apache module aimed at being a C implementation of
+the Perl module Apache::MP3. It allows nice displaying of directories
+containing MP3 or Ogg Vorbis files, including sorting them on various
+fields, streaming/downloading them, constructing playlists, and searching.
+
+WWW: http://www.esiee.fr/~puffin/musicindex/
diff --git a/www/mod_musicindex/pkg-message b/www/mod_musicindex/pkg-message
new file mode 100644
index 000000000000..40abf20f0eea
--- /dev/null
+++ b/www/mod_musicindex/pkg-message
@@ -0,0 +1,26 @@
+************************************************************
+You've installed mod_musicindex
+
+Edit your apache.conf or httpd.conf to enable and setup this
+module.
+
+And sample Directory configuration should looks like this:
+
+<Directory /usr/local/www/data/musicindex/>
+ Options Indexes MultiViews FollowSymlinks
+ AllowOverride None
+ MusicLister
+ MusicSortOrder artist album track title
+ MusicFields title artist album track length bitrate
+ MusicAllowDownload
+ MusicAllowStream
+ MusicAllowSearch
+ MusicCachePath /tmp/musicindex
+</Directory>
+
+Then do this to make it work effective:
+
+# apachectl configtest (see if there are any config errors)
+# apachectl restart
+
+************************************************************
diff --git a/www/mod_musicindex/pkg-plist b/www/mod_musicindex/pkg-plist
new file mode 100644
index 000000000000..a0105dbfeaad
--- /dev/null
+++ b/www/mod_musicindex/pkg-plist
@@ -0,0 +1,10 @@
+libexec/apache/mod_musicindex.so
+@exec %D/sbin/apxs -e -A -n musicindex %D/%F
+@unexec %D/sbin/apxs -e -A -n musicindex %D/%F
+%%PORTDOCS%%%%DOCSDIR%%/directory.png
+%%PORTDOCS%%%%DOCSDIR%%/fetch.png
+%%PORTDOCS%%%%DOCSDIR%%/general.png
+%%PORTDOCS%%%%DOCSDIR%%/musicindex.css
+%%PORTDOCS%%%%DOCSDIR%%/right_arrow.gif
+%%PORTDOCS%%%%DOCSDIR%%/sound.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%