aboutsummaryrefslogtreecommitdiff
path: root/www/mod_mylo/Makefile
diff options
context:
space:
mode:
authorAnders Nordby <anders@FreeBSD.org>2001-11-12 02:51:50 +0000
committerAnders Nordby <anders@FreeBSD.org>2001-11-12 02:51:50 +0000
commita87a019bc08e6161cbb2d4fac83da912824c69c1 (patch)
tree5c39f02163dbeee2ccd975e58b97c3d0670b9c32 /www/mod_mylo/Makefile
parent4417a778f41170679f5eabb971094cd5c89b7c76 (diff)
downloadports-a87a019bc08e6161cbb2d4fac83da912824c69c1.tar.gz
ports-a87a019bc08e6161cbb2d4fac83da912824c69c1.zip
Notes
Diffstat (limited to 'www/mod_mylo/Makefile')
-rw-r--r--www/mod_mylo/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/www/mod_mylo/Makefile b/www/mod_mylo/Makefile
new file mode 100644
index 000000000000..7f4f3fc8d41e
--- /dev/null
+++ b/www/mod_mylo/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_mylo
+# Date created: 12 November 2001
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= mod_mylo
+PORTVERSION= 0.2.1
+CATEGORIES= www
+MASTER_SITES= http://www.orakel.ntnu.no/~oyving/code/mod_mylo/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@FreeBSD.org
+
+BUILD_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+RUN_DEPENDS= ${APXS}:${PORTSDIR}/www/apache13
+LIB_DEPENDS= mysqlclient.10:${PORTSDIR}/databases/mysql323-client
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+APXS= ${LOCALBASE}/sbin/apxs
+DOCS= mod_mylo.sql README
+
+do-build:
+ (cd ${WRKSRC} && ${APXS} -c -I${LOCALBASE}/include \
+ -L${LOCALBASE}/lib/mysql -lmysqlclient mod_mylo.c)
+
+do-install:
+ (cd ${WRKSRC} && ${APXS} -i -A -n 'mylo' mod_mylo.so)
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d -o root -g wheel -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>