aboutsummaryrefslogtreecommitdiff
path: root/www/mod_myvhost/Makefile
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-07-08 19:53:24 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-07-08 19:53:24 +0000
commit595048ebe646f6e98dfdaf219cf5721d9889a773 (patch)
treee8f71fb6050bfe2e366c181736847724c3d2e0d2 /www/mod_myvhost/Makefile
parentffe437819d89103c0f0d765f276f1430769e37fc (diff)
Notes
Diffstat (limited to 'www/mod_myvhost/Makefile')
-rw-r--r--www/mod_myvhost/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/www/mod_myvhost/Makefile b/www/mod_myvhost/Makefile
index 96eca26d10a7..a5fa852a7009 100644
--- a/www/mod_myvhost/Makefile
+++ b/www/mod_myvhost/Makefile
@@ -27,17 +27,20 @@ PORTDOCS= changelog.html documentation.html download.html \
index.html my.css
PORTEXAMPLES= vhosts.sql httpd.conf.add
-OPTIONS= PHP_MODULE "Enable PHP" on \
- DEBUG_MODULE "Enable debigging" off
+OPTIONS_DEFINE= PHP_MODULE DEBUG_MODULE PHP DEBUG
+OPTIONS_DEFAULT= PHP_MODULE
+
+PHP_MODULE_DESC= Enable PHP
+DEBUG_MODULE_DESC= Enable debugging
.include <bsd.port.options.mk>
-.if defined(WITH_DEBUG_MODULE)
+.if ${PORT_OPTIONS:MDEBUG_MODULE}
MAKE_ENV+= WITH_DEBUG=true
STRIP= # keep debug information
.endif
-.if defined(WITH_PHP_MODULE)
+.if ${PORT_OPTIONS:MPHP_MODULE}
MAKE_ENV+= WITH_PHP=true
USE_PHP= yes
USE_PHP_MOD= yes
@@ -51,11 +54,11 @@ pre-patch:
-e "s|= cp|= ${CP}|" ${WRKSRC}/Makefile
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
@cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
.endif