aboutsummaryrefslogtreecommitdiff
path: root/www/mod_ntlm2
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2007-09-26 12:38:30 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2007-09-26 12:38:30 +0000
commit05d11e1a42cc8d4243fa82fc0786fbee7d1f2477 (patch)
treec215735e63f939ce3b8ce02e4a759070381cf75c /www/mod_ntlm2
parent732672fa4ad0ca1f03c54131c4696b485f8c7104 (diff)
downloadports-05d11e1a42cc8d4243fa82fc0786fbee7d1f2477.tar.gz
ports-05d11e1a42cc8d4243fa82fc0786fbee7d1f2477.zip
Notes
Diffstat (limited to 'www/mod_ntlm2')
-rw-r--r--www/mod_ntlm2/Makefile23
-rw-r--r--www/mod_ntlm2/distinfo3
-rw-r--r--www/mod_ntlm2/files/patch-Makefile20
-rw-r--r--www/mod_ntlm2/files/patch-smbval-rfcnb-util.inc.c11
-rw-r--r--www/mod_ntlm2/files/patch-smbval-session.inc.c11
-rw-r--r--www/mod_ntlm2/files/patch-smbval-smbencrypt.inc.c12
-rw-r--r--www/mod_ntlm2/files/patch-smbval-smblib-util.inc.c11
-rw-r--r--www/mod_ntlm2/files/patch-smbval-smblib.inc.c11
-rw-r--r--www/mod_ntlm2/pkg-descr11
-rw-r--r--www/mod_ntlm2/pkg-plist3
10 files changed, 116 insertions, 0 deletions
diff --git a/www/mod_ntlm2/Makefile b/www/mod_ntlm2/Makefile
new file mode 100644
index 000000000000..806957f92271
--- /dev/null
+++ b/www/mod_ntlm2/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mod_ntlm2
+# Date created: 26 September 2007
+# Whom: Alex "lissyara" Keda <admin@lissyara.su>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_ntlm2
+PORTVERSION= 0.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= modntlm
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= admin@lissyara.su
+COMMENT= NTLM authentication module for the Apache2 webserver
+
+USE_APACHE= 20+
+MAKE_ENV= APXS=${APXS}
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/smbclient:${PORTSDIR}/net/samba3
+
+.include <bsd.port.mk>
diff --git a/www/mod_ntlm2/distinfo b/www/mod_ntlm2/distinfo
new file mode 100644
index 000000000000..feb39090724f
--- /dev/null
+++ b/www/mod_ntlm2/distinfo
@@ -0,0 +1,3 @@
+MD5 (mod_ntlm2-0.1.tgz) = 8abe4f235af6825f723412e187cac96b
+SHA256 (mod_ntlm2-0.1.tgz) = 156add771495f0321824c978d8da748de7446687c15a9cd5ba6c88d7a8cf97f6
+SIZE (mod_ntlm2-0.1.tgz) = 41247
diff --git a/www/mod_ntlm2/files/patch-Makefile b/www/mod_ntlm2/files/patch-Makefile
new file mode 100644
index 000000000000..9245b0677a3a
--- /dev/null
+++ b/www/mod_ntlm2/files/patch-Makefile
@@ -0,0 +1,20 @@
+--- Makefile.orig Tue Feb 25 14:25:42 2003
++++ Makefile Wed Sep 26 13:29:56 2007
+@@ -6,7 +6,7 @@
+
+ # the used tools
+ APXS=apxs
+-APACHECTL=/etc/rc.d/apache
++APACHECTL=${PREFIX}/sbin/apachectl
+
+ # the default target
+ all: mod_ntlm.so
+@@ -17,7 +17,7 @@
+
+ # install the shared object file into Apache
+ install: all
+- $(APXS) -i -a -n 'ntlm' mod_ntlm.so
++ $(APXS) -i -a -n 'ntlm' .libs/mod_ntlm.so
+
+ # cleanup
+ clean:
diff --git a/www/mod_ntlm2/files/patch-smbval-rfcnb-util.inc.c b/www/mod_ntlm2/files/patch-smbval-rfcnb-util.inc.c
new file mode 100644
index 000000000000..f4add85dc3ba
--- /dev/null
+++ b/www/mod_ntlm2/files/patch-smbval-rfcnb-util.inc.c
@@ -0,0 +1,11 @@
+--- smbval/rfcnb-util.inc.c.orig Wed Sep 26 12:46:02 2007
++++ smbval/rfcnb-util.inc.c Wed Sep 26 12:47:13 2007
+@@ -21,7 +21,7 @@
+ * 675 Mass Ave, Cambridge, MA 02139, USA. */
+
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #include "std-includes.h"
+ #include "rfcnb-priv.h"
diff --git a/www/mod_ntlm2/files/patch-smbval-session.inc.c b/www/mod_ntlm2/files/patch-smbval-session.inc.c
new file mode 100644
index 000000000000..71b7d6814c47
--- /dev/null
+++ b/www/mod_ntlm2/files/patch-smbval-session.inc.c
@@ -0,0 +1,11 @@
+--- smbval/session.inc.c.orig Wed Sep 26 12:40:51 2007
++++ smbval/session.inc.c Wed Sep 26 12:41:45 2007
+@@ -21,7 +21,7 @@
+ * with this program; if not, write to the Free Software Foundation, Inc.,
+ * 675 Mass Ave, Cambridge, MA 02139, USA. */
+
+-#include <malloc.h>
++#include <stdlib.h>
+ #include <string.h>
+
+ static int RFCNB_errno = 0;
diff --git a/www/mod_ntlm2/files/patch-smbval-smbencrypt.inc.c b/www/mod_ntlm2/files/patch-smbval-smbencrypt.inc.c
new file mode 100644
index 000000000000..195b05a414f7
--- /dev/null
+++ b/www/mod_ntlm2/files/patch-smbval-smbencrypt.inc.c
@@ -0,0 +1,12 @@
+--- smbval/smbencrypt.inc.c.orig Wed Sep 26 12:43:32 2007
++++ smbval/smbencrypt.inc.c Wed Sep 26 12:45:29 2007
+@@ -19,7 +19,8 @@
+ #include <arpa/inet.h>
+ #include <dirent.h>
+ #include <string.h>
+-#include <sys/vfs.h>
++#include <sys/param.h>
++#include <sys/mount.h>
+ #include <netinet/in.h>
+
+ #include "smblib-priv.h"
diff --git a/www/mod_ntlm2/files/patch-smbval-smblib-util.inc.c b/www/mod_ntlm2/files/patch-smbval-smblib-util.inc.c
new file mode 100644
index 000000000000..dc6a199fdf4f
--- /dev/null
+++ b/www/mod_ntlm2/files/patch-smbval-smblib-util.inc.c
@@ -0,0 +1,11 @@
+--- smbval/smblib-util.inc.c.orig Wed Sep 26 12:47:37 2007
++++ smbval/smblib-util.inc.c Wed Sep 26 12:47:57 2007
+@@ -21,7 +21,7 @@
+ * 675 Mass Ave, Cambridge, MA 02139, USA. */
+
+ #include "smblib-priv.h"
+-#include <malloc.h>
++#include <stdlib.h>
+
+ #include "rfcnb.h"
+
diff --git a/www/mod_ntlm2/files/patch-smbval-smblib.inc.c b/www/mod_ntlm2/files/patch-smbval-smblib.inc.c
new file mode 100644
index 000000000000..4a985c6182b2
--- /dev/null
+++ b/www/mod_ntlm2/files/patch-smbval-smblib.inc.c
@@ -0,0 +1,11 @@
+--- smbval/smblib.inc.c.orig Wed Sep 26 12:42:22 2007
++++ smbval/smblib.inc.c Wed Sep 26 12:43:08 2007
+@@ -20,7 +20,7 @@
+ * with this program; if not, write to the Free Software Foundation, Inc.,
+ * 675 Mass Ave, Cambridge, MA 02139, USA. */
+ #include <stdio.h>
+-#include <malloc.h>
++#include <stdlib.h>
+
+ static int SMBlib_errno;
+ static int SMBlib_SMB_Error;
diff --git a/www/mod_ntlm2/pkg-descr b/www/mod_ntlm2/pkg-descr
new file mode 100644
index 000000000000..3f27133579c9
--- /dev/null
+++ b/www/mod_ntlm2/pkg-descr
@@ -0,0 +1,11 @@
+NTLM is an authentication protocol used by Microsoft Internet
+Informations Server(tm) and Microsoft Internet Explorer(tm). While it
+is not really secure, it offers background authentication (the
+workstation logon credentials of users are passed through to the web
+server). This feature is widely used in intranets based on these
+Microsoft products.
+
+This module is implementing NTLM authentication for Apache2 on Unix
+platforms.
+
+WWW: http://modntlm.sourceforge.net/
diff --git a/www/mod_ntlm2/pkg-plist b/www/mod_ntlm2/pkg-plist
new file mode 100644
index 000000000000..283b42c25698
--- /dev/null
+++ b/www/mod_ntlm2/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_ntlm.so
+@exec %D/sbin/apxs -e -A -n ntlm %D/%f
+@unexec %D/sbin/apxs -e -A -n ntlm %D/%F