aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2/Makefile
diff options
context:
space:
mode:
authorSheldon Hearn <sheldonh@FreeBSD.org>1999-11-05 14:50:26 +0000
committerSheldon Hearn <sheldonh@FreeBSD.org>1999-11-05 14:50:26 +0000
commit4d35bc6ad0cd35f5d034a7b5fb6d00effc9a0ee5 (patch)
tree7b81038681dddb75a3ee7ec312939af5156ad668 /www/mod_perl2/Makefile
parentda35e30718eaac1d336d7091fe06189e2e11d3ae (diff)
downloadports-4d35bc6ad0cd35f5d034a7b5fb6d00effc9a0ee5.tar.gz
ports-4d35bc6ad0cd35f5d034a7b5fb6d00effc9a0ee5.zip
Notes
Diffstat (limited to 'www/mod_perl2/Makefile')
-rw-r--r--www/mod_perl2/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
new file mode 100644
index 000000000000..204d8a2202fd
--- /dev/null
+++ b/www/mod_perl2/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: p5-Apache
+# Version required: 1.19
+# Date created: April 26th 1997
+# Whom: James FitzGibbon <jfitz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+DISTNAME= mod_perl-1.21
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Apache
+
+MAINTAINER= sheldonh@FreeBSD.org
+
+RUN_DEPENDS= ${PREFIX}/sbin/apxs:${PORTSDIR}/www/apache13
+
+USE_PERL5= YES
+
+MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
+ Apache::FakeRequest.3 Apache::Leak.3 \
+ Apache::Log.3 Apache::Options.3 \
+ Apache::PerlRun.3 Apache::PerlRunXS.3 \
+ Apache::RedirectLogFix.3 \
+ Apache::Registry.3 Apache::SizeLimit.3 \
+ Apache::Status.3 Apache::Symbol.3 Apache::Symdump.3 \
+ Apache::Table.3 Apache::URI.3 Apache::Util.3 \
+ Apache::httpd_conf.3 Apache::src.3 Bundle::Apache.3 \
+ Apache::Debug.3 mod_perl.3 Apache::SIG.3 Apache::Resource.3 \
+ Apache::RegistryLoader.3 Apache::StatINC.3 Apache::Include.3 \
+ Apache::PerlSections.3 cgi_to_mod_perl.3 \
+ mod_perl_cvs.3 mod_perl_method_handlers.3 mod_perl_traps.3 \
+ mod_perl_tuning.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+do-configure:
+ @ cd ${WRKSRC}; \
+ ${PERL5} Makefile.PL USE_APXS=1 EVERYTHING=1 \
+ WITH_APXS=${PREFIX}/sbin/apxs \
+ PERL_EXTRA_CFLAGS='-DDEFAULT_PATH=\"/bin:/usr/bin:/usr/local/bin\"'
+
+post-install:
+ @ ${SH} ${PKGINSTALL}
+
+.include <bsd.port.mk>