aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2/Makefile
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-09-02 07:13:13 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-09-02 07:13:13 +0000
commit83c5a7af15fa39f4973afe5a6a02f7dacc9211d5 (patch)
treef7c9ad88612b8d7037d6707d352904ebb80e7d07 /www/mod_perl2/Makefile
parente550e8984f268b568f54c894c4c4efa5fca670da (diff)
downloadports-83c5a7af15fa39f4973afe5a6a02f7dacc9211d5.tar.gz
ports-83c5a7af15fa39f4973afe5a6a02f7dacc9211d5.zip
Notes
Diffstat (limited to 'www/mod_perl2/Makefile')
-rw-r--r--www/mod_perl2/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index c5eaef60f0a1..bb79df0f173f 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mod_perl
-PORTVERSION= 1.99r14
+PORTVERSION= 1.99r16
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
http://perl.apache.org/dist/old/
@@ -24,8 +24,9 @@ CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs \
MP_INST_APACHE2=1 PREFIX=${PREFIX}
MAN3= Apache::Build.3 Apache::Test.3 Apache::TestConfig.3 \
- Apache::TestMM.3 Apache::TestReport.3 Apache::TestRequest.3 \
- Apache::TestRun.3 Apache::TestRunPerl.3 Apache::TestSmoke.3 \
+ Apache::TestMB.3 Apache::TestMM.3 Apache::TestReport.3 \
+ Apache::TestRequest.3 Apache::TestRun.3 \
+ Apache::TestRunPerl.3 Apache::TestSmoke.3 \
Apache::TestTrace.3 Apache::TestUtil.3 Bundle::Apache2.3 \
Bundle::ApacheTest.3 ModPerl::CScan.3 ModPerl::Code.3 \
ModPerl::Config.3 mod_perl.3
@@ -37,6 +38,11 @@ MAN3= Apache::Build.3 Apache::Test.3 Apache::TestConfig.3 \
IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
.endif
+# no idea why r16 requires this - the perl build should do this copy
+pre-install:
+ ${CP} ${WRKSRC}/WrapXS/APR/ThreadMutex/ThreadMutex.pm \
+ ${WRKSRC}/blib/lib/Apache2/APR/
+
post-install:
${MKDIR} ${PREFIX}/include/apache2/modules/perl
${INSTALL_DATA} ${WRKSRC}/src/modules/perl/*.h \