aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-01-19 19:30:20 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-01-19 19:30:20 +0000
commit85f0e6088d2b538c2c823788644dfcfdc4505b7a (patch)
tree44a8855d80067b17dec68002c5ec5266ce409a38 /www/mod_perl2
parent91a75361df497f7a428b0ca8079f9257ff07e1eb (diff)
downloadports-85f0e6088d2b538c2c823788644dfcfdc4505b7a.tar.gz
ports-85f0e6088d2b538c2c823788644dfcfdc4505b7a.zip
Notes
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile19
-rw-r--r--www/mod_perl2/pkg-plist2
2 files changed, 17 insertions, 4 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 9b019aa5d215..e03d44c66587 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_perl
PORTVERSION= 2.0.3
-PORTREVISION= 2
+PORTREVISION= 3
PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
@@ -36,7 +36,7 @@ MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
APR::Date.3 APR::Error.3 APR::Finfo.3 APR::IpSubnet.3 \
APR::OS.3 APR::PerlIO.3 APR::Pool.3 APR::SockAddr.3 \
APR::Socket.3 APR::Status.3 APR::String.3 APR::Table.3 \
- APR::ThreadMutex.3 APR::URI.3 APR::UUID.3 APR::Util.3 \
+ APR::URI.3 APR::UUID.3 APR::Util.3 \
Apache2::Access.3 Apache2::Build.3 Apache2::CmdParms.3 \
Apache2::Command.3 Apache2::Connection.3 Apache2::Const.3 \
Apache2::Directive.3 Apache2::Filter.3 Apache2::FilterRec.3 \
@@ -63,7 +63,20 @@ MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
.include <bsd.port.pre.mk>
-.if ${APACHE_VERSION} >= 21
+.if exists(${LOCALBASE}/include/apr-1/apr.h)
+APR_H= ${LOCALBASE}/include/apr-1/apr.h
+.elif exists(${LOCALBASE}/include/apr/apr.h)
+APR_H= ${LOCALBASE}/include/apr/apr.h
+.endif
+
+.if defined(APR_H)
+APR_HAS_THREADS!= ${ECHO_CMD} `${GREP} -c 'APR_HAS_THREADS *1' ${APR_H}`
+.else
+APR_HAS_THREADS= 0
+.endif
+
+.if ${APR_HAS_THREADS} == 1
+MAN3+= APR::ThreadMutex.3
PLIST_SUB+= THREADMUTEX=""
.else
PLIST_SUB+= THREADMUTEX="@comment "
diff --git a/www/mod_perl2/pkg-plist b/www/mod_perl2/pkg-plist
index aa32e3409a0b..5b6796dc65ee 100644
--- a/www/mod_perl2/pkg-plist
+++ b/www/mod_perl2/pkg-plist
@@ -337,7 +337,7 @@ bin/mp2bug
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/APR
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%
@dirrm %%APACHEINCLUDEDIR%%/modules/perl
@dirrmtry %%APACHEINCLUDEDIR%%/modules
@dirrmtry %%APACHEINCLUDEDIR%%