aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-04 00:07:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-04 00:07:10 +0000
commit628531ea87183e11a8b4e52a1b21d3c9f20b8d03 (patch)
tree64027fda9c578017f78c66dd40ee3befd468800f /www/mod_perl2
parent566636722dfea2178dee19a870b89a8a7df1ae9a (diff)
downloadports-628531ea87183e11a8b4e52a1b21d3c9f20b8d03.tar.gz
ports-628531ea87183e11a8b4e52a1b21d3c9f20b8d03.zip
Notes
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile16
-rw-r--r--www/mod_perl2/files/patch-xs-APR-APR-Makefile.PL11
2 files changed, 13 insertions, 14 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 954ed129add2..0ac2acb39c74 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -7,13 +7,14 @@
PORTNAME= mod_perl
PORTVERSION= 2.0.3
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
http://perl.apache.org/dist/old/
PKGNAMESUFFIX= 2
-MAINTAINER= lars.eggert@gmx.net
+MAINTAINER= pgollucci@p6m7g8.com
COMMENT= Embeds a Perl interpreter in the Apache2 server
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/BSD/Resource.pm:${PORTSDIR}/devel/p5-BSD-Resource
@@ -66,19 +67,6 @@ PLIST_SUB= THREADMUTEX=""
PLIST_SUB= THREADMUTEX="@comment "
.endif
-pre-everything::
-.if ${APACHE_VERSION} >= 21
- @${ECHO} "************************************************************"
- @${ECHO} "You are building ${PORTNAME}-${PORTVERSION} for apache${APACHE_VERSION}."
- @${ECHO} ""
- @${ECHO} "Please note that the maintainer only tests ${PORTNAME}-${PORTVERSION}"
- @${ECHO} "with apache20. If you encounter a problem, please roll back"
- @${ECHO} "to that version and verify that the problem still exists,"
- @${ECHO} "before submitting a problem report."
- @${ECHO} "************************************************************"
- @sleep 5
-.endif
-
# it is time to require perl 5.8.x
.if ${PERL_LEVEL} < 500800
IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
diff --git a/www/mod_perl2/files/patch-xs-APR-APR-Makefile.PL b/www/mod_perl2/files/patch-xs-APR-APR-Makefile.PL
new file mode 100644
index 000000000000..34530507ea4f
--- /dev/null
+++ b/www/mod_perl2/files/patch-xs-APR-APR-Makefile.PL
@@ -0,0 +1,11 @@
+--- xs/APR/APR/Makefile.PL.orig Sun Nov 19 15:31:02 2006
++++ xs/APR/APR/Makefile.PL Sun Dec 3 15:30:46 2006
+@@ -15,7 +15,7 @@
+
+ my %args;
+
+-%args = map { split /=/, $_ } @ARGV;
++%args = map { split /=/, $_, 2 } @ARGV;
+
+ $args{NAME} = 'APR';
+ $args{VERSION_FROM} = 'APR.pm';