aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-07 09:12:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-11-07 09:12:58 +0000
commitf4d7c801f854ff4fad4642d62b23bae798962615 (patch)
treeeee60e8fb7c2a2d1bf0636dd8288df46aee9e9bb /www/mod_perl2
parent2e8e10b527cd18511e4bd6a598f05050d4190015 (diff)
downloadports-f4d7c801f854ff4fad4642d62b23bae798962615.tar.gz
ports-f4d7c801f854ff4fad4642d62b23bae798962615.zip
Notes
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 169cc60d6d72..cd9cd10428d8 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -17,10 +17,10 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/r/_/}
MAINTAINER= larse@isi.edu
COMMENT= Embeds a Perl interpreter in the Apache2 server
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${APACHE2_PORT}
-RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${APACHE2_PORT}
-
+USE_APACHE= yes
+WITH_APACHE2= yes
PERL_CONFIGURE= yes
+
CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs \
MP_INST_APACHE2=1 PREFIX=${PREFIX}
@@ -29,8 +29,6 @@ MAN3= Apache::TestRequest.3 Apache::TestSmoke.3 Apache::TestRun.3 \
Apache::Test.3 Apache::TestUtil.3 Apache::Build.3 \
Bundle::Apache2.3 ModPerl::Code.3
-APACHE2_PORT?= ${PORTSDIR}/www/apache2
-
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} > 500601