aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorOlli Hauer <ohauer@FreeBSD.org>2012-09-22 21:15:50 +0000
committerOlli Hauer <ohauer@FreeBSD.org>2012-09-22 21:15:50 +0000
commitb7fc7ba65576d5ce387563c60b88276ba1418bc8 (patch)
tree884d351fee646b4e7b1b5c851bf898976e69b28e /www/mod_perl2
parent221e0a651fd2a964309073001ac7cc62e1b96ea0 (diff)
downloadports-b7fc7ba65576d5ce387563c60b88276ba1418bc8.tar.gz
ports-b7fc7ba65576d5ce387563c60b88276ba1418bc8.zip
Notes
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 3dc557629392..12a04014bbd1 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -29,11 +29,6 @@ PERL_CONFIGURE= yes
GMAKE= yes
USE_CSTD= gnu89
-# Using apxs in this way is problematic if apache2 is installed under a
-# different PREFIX than mod_perl2, because the mod_perl2 installation will
-# use paths returned by apxs to install some components. Fixes welcome.
-CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs PREFIX=${PREFIX}
-
MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
APR::BucketAlloc.3 APR::BucketType.3 APR::Const.3 \
APR::Date.3 APR::Error.3 APR::Finfo.3 APR::IpSubnet.3 \
@@ -70,6 +65,12 @@ MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
.include <bsd.port.pre.mk>
+# Using apxs in this way is problematic if apache2 is installed under a
+# different PREFIX than mod_perl2, because the mod_perl2 installation will
+# use paths returned by apxs to install some components. Fixes welcome.
+#CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs PREFIX=${PREFIX}
+CONFIGURE_ARGS= PREFIX=${PREFIX} MP_APXS=${APXS} MP_APR_CONFIG=${LOCALBASE}/bin/apr-1-config
+
.if exists(${LOCALBASE}/include/apr-1/apr.h)
APR_H= ${LOCALBASE}/include/apr-1/apr.h
APR_MAJ_V!= ${ECHO_CMD} `${LOCALBASE}/bin/apr-1-config --version | ${SED} -e 's,\..*,,'`