aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-05-14 16:14:12 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-05-14 16:14:12 +0000
commitbf806e9372a51d601dc5ed768e34f50b49367bf3 (patch)
tree96d72466c8ccddc47d8ef209021868ec02dc59fe /www/mod_perl2
parentf26daa7f4eb0a3ca08d9a107074d3ba7a9f7913a (diff)
downloadports-bf806e9372a51d601dc5ed768e34f50b49367bf3.tar.gz
ports-bf806e9372a51d601dc5ed768e34f50b49367bf3.zip
Notes
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile25
-rw-r--r--www/mod_perl2/distinfo4
-rw-r--r--www/mod_perl2/pkg-message2
-rw-r--r--www/mod_perl2/pkg-plist13
4 files changed, 18 insertions, 26 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index 345663d4aa76..01f132a43d04 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mod_perl
-PORTVERSION= 1.99r12
-PORTREVISION= 1
+PORTVERSION= 1.99r13
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
http://perl.apache.org/dist/old/
@@ -24,23 +23,17 @@ PERL_CONFIGURE= yes
CONFIGURE_ARGS= MP_APXS=${LOCALBASE}/sbin/apxs \
MP_INST_APACHE2=1 PREFIX=${PREFIX}
-MAN3= Apache::TestRequest.3 Apache::TestSmoke.3 Apache::TestRun.3 \
- Apache::TestTrace.3 Apache::TestMM.3 Bundle::ApacheTest.3 \
- Apache::Test.3 Apache::TestUtil.3 Apache::Build.3 \
- Apache::TestReport.3 \
- Bundle::Apache2.3 ModPerl::Code.3 mod_perl.3
+MAN3= Apache::Build.3 Apache::Test.3 Apache::TestConfig.3 \
+ Apache::TestMM.3 Apache::TestReport.3 Apache::TestRequest.3 \
+ Apache::TestRun.3 Apache::TestSmoke.3 Apache::TestTrace.3 \
+ Apache::TestUtil.3 Bundle::Apache2.3 Bundle::ApacheTest.3 \
+ ModPerl::Code.3 ModPerl::Config.3 mod_perl.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} > 500601
-MAN3+= ModPerl::Config.3 Apache::TestConfig.3
-.endif
-
-##
-## this port requires PERL 5.6.x or later
-##
-.if ${PERL_LEVEL} < 500600
-IGNORE= requires perl 5.6.x or later. Install lang/perl5 then try again
+# it is time to require perl 5.8.x
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
.endif
post-install:
diff --git a/www/mod_perl2/distinfo b/www/mod_perl2/distinfo
index e5c82abd0d43..6e5af098d48a 100644
--- a/www/mod_perl2/distinfo
+++ b/www/mod_perl2/distinfo
@@ -1,2 +1,2 @@
-MD5 (mod_perl-1.99_12.tar.gz) = 3864841c530cceeace86a6017ce5fffd
-SIZE (mod_perl-1.99_12.tar.gz) = 1113684
+MD5 (mod_perl-1.99_13.tar.gz) = e8945611cae2fe797ae4bb198c0285b6
+SIZE (mod_perl-1.99_13.tar.gz) = 1197628
diff --git a/www/mod_perl2/pkg-message b/www/mod_perl2/pkg-message
index a3d18f4bc4e0..bb1566aef023 100644
--- a/www/mod_perl2/pkg-message
+++ b/www/mod_perl2/pkg-message
@@ -1,4 +1,3 @@
-
#########################################################
Enable mod_perl built as DSO, by adding to httpd.conf:
@@ -15,4 +14,3 @@ find in the configuration manual:
http://perl.apache.org/docs/2.0/user/config/config.html
#########################################################
-
diff --git a/www/mod_perl2/pkg-plist b/www/mod_perl2/pkg-plist
index ea4e92c86032..c43795718a76 100644
--- a/www/mod_perl2/pkg-plist
+++ b/www/mod_perl2/pkg-plist
@@ -1,8 +1,5 @@
bin/mp2bug
bin/mp2doc
-include/apache2/modperl_xs_sv_convert.h
-include/apache2/modperl_xs_typedefs.h
-include/apache2/modperl_xs_util.h
include/apache2/modules/perl/mod_perl.h
include/apache2/modules/perl/modperl_apache_compat.h
include/apache2/modules/perl/modperl_apache_includes.h
@@ -104,6 +101,7 @@ include/apache2/modules/perl/modperl_util.h
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/Module.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/ParseSource.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/PerlSections.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/PerlSections/Dump.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/Process.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/Reload.pm
%%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/RequestIO.pm
@@ -239,8 +237,9 @@ include/apache2/modules/perl/modperl_util.h
%%SITE_PERL%%/%%PERL_ARCH%%/Bundle/ApacheTest.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/mod_perl/.packlist
libexec/apache2/mod_perl.so
+@unexec rmdir %D/libexec/apache2 2>/dev/null || true
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/mod_perl
-@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Bundle 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Bundle
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/ModPerl/Util
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/ModPerl/Global
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/ModPerl/Const
@@ -280,8 +279,8 @@ libexec/apache2/mod_perl.so
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Pool
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/PerlIO
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/OS
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Finfo
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/NetLib
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Finfo
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Date
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Const
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR/Bucket
@@ -290,9 +289,11 @@ libexec/apache2/mod_perl.so
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto/APR
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/auto
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/ModPerl
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache/PerlSections
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/Apache
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2/APR
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache2
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache
@dirrm include/apache2/modules/perl
-@dirrm include/apache2/modules
+@unexec rmdir %D/include/apache2/modules 2>/dev/null || true
+@unexec rmdir %D/include/apache2 2>/dev/null || true