aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl2
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:45:27 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:45:27 +0000
commitca440181c3838b2d560b9ae63e4afa8bcc66ff25 (patch)
tree5c960e56cee734cf4a350c4b93db80ccdc65efe6 /www/mod_perl2
parentb76099f8c6e2c3a5a26c781e75bab88d47e33bd8 (diff)
downloadports-ca440181c3838b2d560b9ae63e4afa8bcc66ff25.tar.gz
ports-ca440181c3838b2d560b9ae63e4afa8bcc66ff25.zip
Notes
Diffstat (limited to 'www/mod_perl2')
-rw-r--r--www/mod_perl2/Makefile34
-rw-r--r--www/mod_perl2/distinfo1
-rw-r--r--www/mod_perl2/pkg-plist104
3 files changed, 71 insertions, 68 deletions
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index f3fa3660778d..4b697ffd24fb 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mod_perl
PORTVERSION= 2.0.2
-PORTEPOCH= 2
+PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
http://perl.apache.org/dist/old/
@@ -16,8 +16,7 @@ PKGNAMESUFFIX= 2
MAINTAINER= lars.eggert@gmx.net
COMMENT= Embeds a Perl interpreter in the Apache2 server
-USE_APACHE= yes
-WITH_APACHE2= yes
+USE_APACHE= 2.0+
PERL_CONFIGURE= yes
GMAKE= yes
@@ -56,17 +55,20 @@ MAN3= APR.3 APR::Base64.3 APR::Brigade.3 APR::Bucket.3 \
ModPerl::RegistryLoader.3 ModPerl::RegistryPrefork.3 \
ModPerl::Util.3 mod_perl2.3
+.include <bsd.port.pre.mk>
+
pre-everything::
+.if ${APACHE_VERSION} >= 21
@${ECHO} "************************************************************"
- @${ECHO} "NOTE: Version 2.0.0-RC5 and higher of ${PORTNAME}"
- @${ECHO} " significantly change the API - old code *will* break!"
- @${ECHO} " See http://perl.apache.org/docs/2.0/rename.html"
+ @${ECHO} "You are building ${PORTNAME}-${PORTVERSION} for apache${APACHE_VERSION}."
@${ECHO} ""
- @${ECHO} "Hit Ctrl-C to abort now, if this is of concern."
+ @${ECHO} "Please note that the maintainer only tests ${PORTNAME}-${PORTVERSION}"
+ @${ECHO} "with apache20. If you encounter a problem, please roll back"
+ @${ECHO} "to that version and verify that the problem still exists,"
+ @${ECHO} "before submitting a problem report."
@${ECHO} "************************************************************"
- @sleep 10
-
-.include <bsd.port.pre.mk>
+ @sleep 5
+.endif
# it is time to require perl 5.8.x
.if ${PERL_LEVEL} < 500800
@@ -74,14 +76,14 @@ IGNORE= requires perl 5.8.x or later. Install lang/perl5.8 then try again
.endif
post-install:
- ${MKDIR} ${PREFIX}/include/apache2/modules/perl
+ ${MKDIR} ${PREFIX}/${APACHEINCLUDEDIR}/modules/perl
${INSTALL_DATA} ${WRKSRC}/src/modules/perl/*.h \
- ${PREFIX}/include/apache2/modules/perl
- ${INSTALL_DATA} ${WRKSRC}/xs/*.h ${PREFIX}/include/apache2
- ${INSTALL_DATA} ${WRKSRC}/xs/APR/PerlIO/*.h ${PREFIX}/include/apache2
- ${MKDIR} ${PREFIX}/libexec/apache2
+ ${PREFIX}/${APACHEINCLUDEDIR}/modules/perl
+ ${INSTALL_DATA} ${WRKSRC}/xs/*.h ${PREFIX}/${APACHEINCLUDEDIR}
+ ${INSTALL_DATA} ${WRKSRC}/xs/APR/PerlIO/*.h ${PREFIX}/${APACHEINCLUDEDIR}
+ ${MKDIR} ${PREFIX}/${APACHEMODDIR}
${INSTALL_PROGRAM} ${WRKSRC}/src/modules/perl/mod_perl.so \
- ${PREFIX}/libexec/apache2/mod_perl.so
+ ${PREFIX}/${APACHEMODDIR}/mod_perl.so
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/mod_perl2/distinfo b/www/mod_perl2/distinfo
index b6c964fbf8b4..b51105a3485c 100644
--- a/www/mod_perl2/distinfo
+++ b/www/mod_perl2/distinfo
@@ -1,2 +1,3 @@
MD5 (mod_perl-2.0.2.tar.gz) = ad0a509fd34e3b8452887d80a1d45dea
+SHA256 (mod_perl-2.0.2.tar.gz) = 64a3f54111c953c46ed7b1bafb4ebb034447ca6baba73a8657ad7a39ddeca906
SIZE (mod_perl-2.0.2.tar.gz) = 3692744
diff --git a/www/mod_perl2/pkg-plist b/www/mod_perl2/pkg-plist
index 4935512b690c..7115eae7034a 100644
--- a/www/mod_perl2/pkg-plist
+++ b/www/mod_perl2/pkg-plist
@@ -1,56 +1,56 @@
bin/mp2bug
-include/apache2/modperl_apr_perlio.h
-include/apache2/modperl_xs_sv_convert.h
-include/apache2/modperl_xs_typedefs.h
-include/apache2/modperl_xs_util.h
-include/apache2/modules/perl/mod_perl.h
-include/apache2/modules/perl/modperl_apache_compat.h
-include/apache2/modules/perl/modperl_apache_includes.h
-include/apache2/modules/perl/modperl_apr_compat.h
-include/apache2/modules/perl/modperl_apr_includes.h
-include/apache2/modules/perl/modperl_bucket.h
-include/apache2/modules/perl/modperl_callback.h
-include/apache2/modules/perl/modperl_cgi.h
-include/apache2/modules/perl/modperl_cmd.h
-include/apache2/modules/perl/modperl_common_debug.h
-include/apache2/modules/perl/modperl_common_includes.h
-include/apache2/modules/perl/modperl_common_log.h
-include/apache2/modules/perl/modperl_common_types.h
-include/apache2/modules/perl/modperl_common_util.h
-include/apache2/modules/perl/modperl_config.h
-include/apache2/modules/perl/modperl_const.h
-include/apache2/modules/perl/modperl_constants.h
-include/apache2/modules/perl/modperl_debug.h
-include/apache2/modules/perl/modperl_directives.h
-include/apache2/modules/perl/modperl_env.h
-include/apache2/modules/perl/modperl_error.h
-include/apache2/modules/perl/modperl_filter.h
-include/apache2/modules/perl/modperl_flags.h
-include/apache2/modules/perl/modperl_global.h
-include/apache2/modules/perl/modperl_gtop.h
-include/apache2/modules/perl/modperl_handler.h
-include/apache2/modules/perl/modperl_hooks.h
-include/apache2/modules/perl/modperl_interp.h
-include/apache2/modules/perl/modperl_io.h
-include/apache2/modules/perl/modperl_io_apache.h
-include/apache2/modules/perl/modperl_largefiles.h
-include/apache2/modules/perl/modperl_log.h
-include/apache2/modules/perl/modperl_mgv.h
-include/apache2/modules/perl/modperl_module.h
-include/apache2/modules/perl/modperl_options.h
-include/apache2/modules/perl/modperl_pcw.h
-include/apache2/modules/perl/modperl_perl.h
-include/apache2/modules/perl/modperl_perl_global.h
-include/apache2/modules/perl/modperl_perl_includes.h
-include/apache2/modules/perl/modperl_perl_pp.h
-include/apache2/modules/perl/modperl_perl_unembed.h
-include/apache2/modules/perl/modperl_svptr_table.h
-include/apache2/modules/perl/modperl_sys.h
-include/apache2/modules/perl/modperl_time.h
-include/apache2/modules/perl/modperl_tipool.h
-include/apache2/modules/perl/modperl_trace.h
-include/apache2/modules/perl/modperl_types.h
-include/apache2/modules/perl/modperl_util.h
+%%APACHEINCLUDEDIR%%/modperl_apr_perlio.h
+%%APACHEINCLUDEDIR%%/modperl_xs_sv_convert.h
+%%APACHEINCLUDEDIR%%/modperl_xs_typedefs.h
+%%APACHEINCLUDEDIR%%/modperl_xs_util.h
+%%APACHEINCLUDEDIR%%/modules/perl/mod_perl.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_apache_compat.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_apache_includes.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_apr_compat.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_apr_includes.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_bucket.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_callback.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_cgi.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_cmd.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_common_debug.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_common_includes.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_common_log.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_common_types.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_common_util.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_config.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_const.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_constants.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_debug.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_directives.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_env.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_error.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_filter.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_flags.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_global.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_gtop.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_handler.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_hooks.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_interp.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_io.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_io_apache.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_largefiles.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_log.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_mgv.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_module.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_options.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_pcw.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_perl.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_perl_global.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_perl_includes.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_perl_pp.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_perl_unembed.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_svptr_table.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_sys.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_time.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_tipool.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_trace.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_types.h
+%%APACHEINCLUDEDIR%%/modules/perl/modperl_util.h
%%SITE_PERL%%/%%PERL_ARCH%%/APR.pm
%%SITE_PERL%%/%%PERL_ARCH%%/APR/Base64.pm
%%SITE_PERL%%/%%PERL_ARCH%%/APR/Brigade.pm