aboutsummaryrefslogtreecommitdiff
path: root/www/mod_perl
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-11 02:30:44 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-11 02:30:44 +0000
commit15095e4c4c8be388f3b25b046a5005ba7e70a417 (patch)
tree607e3d85c5abb2f123f31d76e51d0f1ad396526b /www/mod_perl
parent9e049c5476109ab9735ea72455c3d33f8167328f (diff)
downloadports-15095e4c4c8be388f3b25b046a5005ba7e70a417.tar.gz
ports-15095e4c4c8be388f3b25b046a5005ba7e70a417.zip
Notes
Diffstat (limited to 'www/mod_perl')
-rw-r--r--www/mod_perl/Makefile16
-rw-r--r--www/mod_perl/pkg-plist4
2 files changed, 7 insertions, 13 deletions
diff --git a/www/mod_perl/Makefile b/www/mod_perl/Makefile
index 5afd8e56e3dd..6aaaa38d4819 100644
--- a/www/mod_perl/Makefile
+++ b/www/mod_perl/Makefile
@@ -18,7 +18,11 @@ BUILD_DEPENDS= ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
RUN_DEPENDS= ${BUILD_DEPENDS}
-USE_PERL5= YES
+PERL_CONFIGURE= yes
+CONFIGURE_ARGS+= USE_APXS=1 EVERYTHING=1 INSTALLSITELIB=${SITE_PERL} \
+ INSTALLSITEARCH=${SITE_PERL}/${PERL_ARCH} \
+ WITH_APXS=${APXS} \
+ PERL_EXTRA_CFLAGS='-DDEFAULT_PATH=\"/bin:/usr/bin:/usr/local/bin\"'
MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
Apache::FakeRequest.3 Apache::File.3 Apache::Leak.3 \
@@ -35,19 +39,9 @@ MAN3= Apache.3 Apache::Constants.3 Apache::ExtUtils.3 \
Apache::PerlSections.3 cgi_to_mod_perl.3 \
mod_perl_cvs.3 mod_perl_method_handlers.3 mod_perl_traps.3 \
mod_perl_tuning.3
-PERLSITEDIR= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}
.include <bsd.port.pre.mk>
-do-configure:
- @ cd ${WRKSRC}; \
- ${PERL5} Makefile.PL USE_APXS=1 EVERYTHING=1 \
- PREFIX=${PREFIX} INSTALLSITELIB=${PERLSITEDIR} \
- INSTALLSITEARCH=${PERLSITEDIR}/${PERL_ARCH} \
- INSTALLMAN3DIR=${MANPREFIX}/man/man3 \
- WITH_APXS=${APXS} \
- PERL_EXTRA_CFLAGS='-DDEFAULT_PATH=\"/bin:/usr/bin:/usr/local/bin\"'
-
post-install:
${MKDIR} ${PREFIX}/include/apache/modules/perl
${INSTALL_DATA} ${WRKSRC}/src/modules/perl/*.h \
diff --git a/www/mod_perl/pkg-plist b/www/mod_perl/pkg-plist
index 2b14814a3844..cfe7580378cb 100644
--- a/www/mod_perl/pkg-plist
+++ b/www/mod_perl/pkg-plist
@@ -73,7 +73,7 @@ libexec/apache/libperl.so
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache/Symbol
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Apache
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/mod_perl
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Bundle 2>/dev/null || true
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache/Constants
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Apache
-@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Bundle
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Apache 2>/dev/null || true
@unexec rmdir %D/etc/apache 2> /dev/null || true