aboutsummaryrefslogtreecommitdiff
path: root/www/mod_php3
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2000-02-25 23:53:06 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2000-02-25 23:53:06 +0000
commit9b0dd3c11036cfc76e1e26c09da2968c9015d5df (patch)
tree714a42e12166992ee08c5bba2de6497c8756f22f /www/mod_php3
parent76b2502c1a8d5221dd35980ded7f8a1cf7ab2acb (diff)
downloadports-9b0dd3c11036cfc76e1e26c09da2968c9015d5df.tar.gz
ports-9b0dd3c11036cfc76e1e26c09da2968c9015d5df.zip
Notes
Diffstat (limited to 'www/mod_php3')
-rw-r--r--www/mod_php3/Makefile6
-rw-r--r--www/mod_php3/scripts/configure.php4
2 files changed, 3 insertions, 7 deletions
diff --git a/www/mod_php3/Makefile b/www/mod_php3/Makefile
index e33a1e782637..bab9b52577e5 100644
--- a/www/mod_php3/Makefile
+++ b/www/mod_php3/Makefile
@@ -80,12 +80,6 @@ CONFIGURE_ARGS= --prefix=${PREFIX} \
OPTIM= -DHARD_SERVER_LIMIT=512 \
-DDEFAULT_PATH=\\"${PREFIX}/bin:/bin:/usr/bin\\"
-.if defined(APACHE_PERF_TUNING) && ${APACHE_PERF_TUNING} == YES
-OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024
-CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer \
- -fexpensive-optimizations -ffast-math
-.endif
-
CONFIGURE_ENV= OPTIM='${OPTIM}' LIBS='-L${PREFIX}/lib'
SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
TOUCH="${TOUCH}" \
diff --git a/www/mod_php3/scripts/configure.php b/www/mod_php3/scripts/configure.php
index cd63d8e788f3..65752d828152 100644
--- a/www/mod_php3/scripts/configure.php
+++ b/www/mod_php3/scripts/configure.php
@@ -53,7 +53,9 @@ exec > ${WRKDIRPREFIX}${CURDIR}/Makefile.inc
while [ "$1" ]; do
case $1 in
\"tuning\")
- echo "APACHE_PERF_TUNING= YES"
+ echo "CFLAGS+= -O6 -funroll-loops -fstrength-reduce -fomit-frame-pointer -fexpensive-optimizations -ffast-math"
+ echo "OPTIM+= -DBUFFERED_LOGS -DFD_SETSIZE=1024"
+ echo "CONFIGURE_ENV+= OPTIM='\${OPTIM}'"
;;
\"GD\")
echo "LIB_DEPENDS+= gd.0:\${PORTSDIR}/graphics/gd"