aboutsummaryrefslogtreecommitdiff
path: root/www/mod_php5
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2001-12-25 15:08:34 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2001-12-25 15:08:34 +0000
commit62a1a7ad692568aa8ee6ade41ae7c0a85efd7be4 (patch)
tree5069ce546f6fa95058882d4b919ee7f844131767 /www/mod_php5
parentc00ad5e9510ed0598d7a06198d167a6e6bb44740 (diff)
Notes
Diffstat (limited to 'www/mod_php5')
-rw-r--r--www/mod_php5/scripts/configure.php6
1 files changed, 5 insertions, 1 deletions
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 7b71120d5413..ed74b8d959d1 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -141,8 +141,10 @@ while [ "$1" ]; do
fi
;;
\"SybaseDB\")
- echo "LIB_DEPENDS+= sybdb.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= sybdb.1:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASECT" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc
@@ -152,7 +154,9 @@ while [ "$1" ]; do
;;
\"SybaseCT\")
echo "LIB_DEPENDS+= ct.0:\${PORTSDIR}/databases/freetds"
+ echo "LIB_DEPENDS+= giconv.2:\${PORTSDIR}/converters/libiconv"
echo "CONFIGURE_ARGS+=--with-sybase-ct=\${LOCALBASE}"
+ LIBS="${LIBS} -L\${LOCALBASE}/lib -lgiconv"
if [ "$SYBASEDB" ]; then
echo "SybaseDB and SybaseCT are mutually exclusive." > /dev/stderr
rm -f ${WRKDIRPREFIX}${REALCURDIR}/Makefile.inc