aboutsummaryrefslogtreecommitdiff
path: root/www/mod_php5
diff options
context:
space:
mode:
authorDirk Froemberg <dirk@FreeBSD.org>2000-01-02 17:17:29 +0000
committerDirk Froemberg <dirk@FreeBSD.org>2000-01-02 17:17:29 +0000
commit86f7d83973aadb1729885f62edcf63d1a5bfccfc (patch)
tree6e32df59b08e60a1e7775682346c4f27d9958d1a /www/mod_php5
parent2467e277b43d6f82ec413bee2deaa828afb61311 (diff)
downloadports-86f7d83973aadb1729885f62edcf63d1a5bfccfc.tar.gz
ports-86f7d83973aadb1729885f62edcf63d1a5bfccfc.zip
Notes
Diffstat (limited to 'www/mod_php5')
-rw-r--r--www/mod_php5/Makefile2
-rw-r--r--www/mod_php5/scripts/configure.php14
2 files changed, 3 insertions, 13 deletions
diff --git a/www/mod_php5/Makefile b/www/mod_php5/Makefile
index 5676d2e82dfd..fa1f9318f137 100644
--- a/www/mod_php5/Makefile
+++ b/www/mod_php5/Makefile
@@ -118,7 +118,7 @@ post-extract:
pre-configure:
@cd ${WRKSRC} \
- && ./configure > /dev/null \
+ && CC="${CC}" CFLAGS="${CFLAGS}" ./configure > /dev/null \
&& cd ${WRKDIR}/php-${VERSION_PHP} \
&& ${ECHO_MSG} "===> Configuring for PHP-${VERSION_PHP}" \
&& CC="${CC}" \
diff --git a/www/mod_php5/scripts/configure.php b/www/mod_php5/scripts/configure.php
index 0d64999efa95..69c82360556e 100644
--- a/www/mod_php5/scripts/configure.php
+++ b/www/mod_php5/scripts/configure.php
@@ -15,8 +15,7 @@ fi
Please select desired options:" -1 -1 14 \
tuning "Apache: performance tuning" OFF \
modssl "Apache: SSL support" OFF \
-GD "PHP: GD library support" OFF \
-FreeType "PHP: TrueType font rendering (implies GD)" OFF \
+GD "PHP: GD support & FreeType font rendering" OFF \
zlib "PHP: zlib library support" ON \
mcrypt "PHP: Encryption support" OFF \
mhash "PHP: Crypto-hashing support" OFF \
@@ -61,18 +60,9 @@ while [ "$1" ]; do
;;
\"nothing\")
echo "LIB_DEPENDS+= gd.0:\${PORTSDIR}/graphics/gd"
- echo "PHP_CONF_ARGS+= --with-gd=\${PREFIX}"
- GD=1
- ;;
- \"FreeType\")
- echo "FreeType is DISABLED for now. Ignoring." > /dev/stderr
- ;;
- \"nothing\")
echo "LIB_DEPENDS+= ttf.4:\${PORTSDIR}/print/freetype"
+ echo "PHP_CONF_ARGS+= --with-gd=\${PREFIX}"
echo "PHP_CONF_ARGS+= --with-ttf=\${PREFIX}"
- if [ -z "$GD" ]; then
- set $* \"GD\"
- fi
;;
\"zlib\")
echo "PHP_CONF_ARGS+= --with-zlib"