aboutsummaryrefslogtreecommitdiff
path: root/www/mod_proxy_html
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-07-30 01:08:27 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-07-30 01:08:27 +0000
commit7819763219fe17a7b232cc85559b69c4e9ab77f2 (patch)
tree2d8250746a221f1fb3badc71652f2b80100f98b4 /www/mod_proxy_html
parentcd77cdc855c8fff3f3d6f772fdd4ac402d17a9ca (diff)
downloadports-7819763219fe17a7b232cc85559b69c4e9ab77f2.tar.gz
ports-7819763219fe17a7b232cc85559b69c4e9ab77f2.zip
Notes
Diffstat (limited to 'www/mod_proxy_html')
-rw-r--r--www/mod_proxy_html/Makefile39
-rw-r--r--www/mod_proxy_html/distinfo2
-rw-r--r--www/mod_proxy_html/pkg-descr8
-rw-r--r--www/mod_proxy_html/pkg-plist3
4 files changed, 52 insertions, 0 deletions
diff --git a/www/mod_proxy_html/Makefile b/www/mod_proxy_html/Makefile
new file mode 100644
index 000000000000..5cfc96d5e891
--- /dev/null
+++ b/www/mod_proxy_html/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mod_proxy_html
+# Date created: 2004-07-29
+# Whom: David Lay <dsl@webize.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_proxy_html
+PORTVERSION= 2.1
+CATEGORIES= www
+MASTER_SITES= http://apache.webthing.com/${PORTNAME}/
+DISTNAME= ${PORTNAME}
+EXTRACT_SUFX= .c
+
+MAINTAINER= dsl@webize.com.au
+COMMENT= Apache module for rewriting HTML links in proxied content
+
+USE_GNOME= libxml2
+USE_APACHE= yes
+WITH_APACHE2= yes
+NO_WRKSUBDIR= yes
+
+XML2_INC= ${LOCALBASE}/include/libxml2
+XML2_LIB= ${LOCALBASE}/lib
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} -p ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PORTNAME}.c
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -c -I ${XML2_INC} -L ${XML2_LIB} -lxml2 ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.la)
+ @${ECHO} "================================================================================"
+ @${ECHO} "Enable mod_proxy_html in Apache's config manually."
+ @${ECHO} "================================================================================"
+
+.include <bsd.port.mk>
diff --git a/www/mod_proxy_html/distinfo b/www/mod_proxy_html/distinfo
new file mode 100644
index 000000000000..355f8794ac57
--- /dev/null
+++ b/www/mod_proxy_html/distinfo
@@ -0,0 +1,2 @@
+MD5 (mod_proxy_html.c) = b1828fb7fb9305ef14c583c99e1fed02
+SIZE (mod_proxy_html.c) = 31392
diff --git a/www/mod_proxy_html/pkg-descr b/www/mod_proxy_html/pkg-descr
new file mode 100644
index 000000000000..e01cb254052e
--- /dev/null
+++ b/www/mod_proxy_html/pkg-descr
@@ -0,0 +1,8 @@
+mod_proxy_html is an output filter to rewrite HTML links in a proxy
+situation, to ensure that links work for users outside the proxy. It
+serves the same purpose as Apache's ProxyPassReverse directive does for
+HTTP headers, and is an essential component of a reverse proxy.
+
+WWW: http://apache.webthing.com/mod_proxy_html/
+
+- David Lay <dsl@webize.com.au>
diff --git a/www/mod_proxy_html/pkg-plist b/www/mod_proxy_html/pkg-plist
new file mode 100644
index 000000000000..16c68ff6f9d5
--- /dev/null
+++ b/www/mod_proxy_html/pkg-plist
@@ -0,0 +1,3 @@
+libexec/apache2/mod_proxy_html.so
+@exec %D/sbin/apxs -e -A -n proxy_html %D/%F
+@unexec %D/sbin/apxs -e -A -n proxy_html %D/%F