aboutsummaryrefslogtreecommitdiff
path: root/www/mod_pubcookie
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2006-02-08 03:06:22 +0000
committerBrooks Davis <brooks@FreeBSD.org>2006-02-08 03:06:22 +0000
commit3f20f871d6917f7881bd7a22a497a28879106807 (patch)
treee65b932064add9bef0024f1c4968f7f6f69ec909 /www/mod_pubcookie
parent0ffb6a38d8693b695d9de86c39f8f17023ec3b04 (diff)
Notes
Diffstat (limited to 'www/mod_pubcookie')
-rw-r--r--www/mod_pubcookie/Makefile59
-rw-r--r--www/mod_pubcookie/pkg-descr11
-rw-r--r--www/mod_pubcookie/pkg-plist8
3 files changed, 78 insertions, 0 deletions
diff --git a/www/mod_pubcookie/Makefile b/www/mod_pubcookie/Makefile
new file mode 100644
index 000000000000..6b81b84cd7f9
--- /dev/null
+++ b/www/mod_pubcookie/Makefile
@@ -0,0 +1,59 @@
+# Ports collection makefile for: pubcookie
+# Date created: Sat Jan 21, 2006
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pubcookie
+DISTVERSION= 3.3.0-beta2
+CATEGORIES= www security
+MASTER_SITES= http://pubcookie.org/downloads/
+PKGNAMEPREFIX= mod_
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= A single sign-on system for websites (apache module)
+
+CONFLICTS= pubcookie-login-server-[0-9]*
+
+FILESDIR= ${.CURDIR}/../pubcookie-login-server/files
+MD5_FILE= ${.CURDIR}/../pubcookie-login-server/distinfo
+PATCHDIR= ${.CURDIR}/../pubcookie-login-server/files
+
+HAS_CONFIGURE= YES
+# GNU_CONFIGURE things since we're not installing directly in PREFIX
+CONFIGURE_ARGS+= --prefix=${PC_DIR} ${CONFIGURE_TARGET}
+
+# We want to build the module server
+CONFIGURE_ARGS+= --enable-apache --disable-login
+
+# mod_pubcookie supports other Apache versions, but the port doesn't yet
+USE_APACHE= 20
+CONFIGURE_ARGS+= --with-apxs=${APXS}
+MODULENAME= mod_${PORTNAME}
+#SHORTMODNAME= ${PORTNAME}
+
+USE_OPENSSL= YES
+CONFIGURE_ARGS+= --with-ssl=${OPENSSLBASE}
+
+PC_BASE?= ${PORTNAME}
+PC_DIR= ${PREFIX}/${PC_BASE}
+
+SUB_FILES+= pkg-install
+SUB_LIST+= CONF_FILES="${CONF_FILES}" CONF_DIRS="${CONF_DIRS}"
+PKGINSTALL= ${WRKDIR}/pkg-install
+PKGDEINSTALL= ${PKGINSTALL}
+CONF_FILES+= ${PC_BASE}/config.sample:${PC_BASE}/config
+
+# XXX Add Kerberos
+
+do-install:
+ ${MKDIR} ${PC_DIR}/keys
+ ${INSTALL_PROGRAM} ${WRKSRC}/keyclient ${PC_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/config.sample ${PC_DIR}
+ ${APXS} -i -A -n ${SHORTMODNAME} ${WRKSRC}/module/${MODULENAME}.${AP_BUILDEXT}
+
+post-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+
+.include <bsd.port.mk>
diff --git a/www/mod_pubcookie/pkg-descr b/www/mod_pubcookie/pkg-descr
new file mode 100644
index 000000000000..12f80ba8cfed
--- /dev/null
+++ b/www/mod_pubcookie/pkg-descr
@@ -0,0 +1,11 @@
+Pubcookie is an open-source package for intra-institutional
+single-sign-on end-user web authentication. More generally, it is an
+approach to identifying users as they browse to an institution's many
+websites that require authentication. It helps an institution reuse
+existing authentication services (like Kerberos, LDAP, or NIS), and it
+limits the exposure of end-user passwords by ensuring they're only sent
+to a trusted login service.
+
+This port contains the Apache module portion of the Pubcookie system.
+
+WWW: http://pubcookie.org/
diff --git a/www/mod_pubcookie/pkg-plist b/www/mod_pubcookie/pkg-plist
new file mode 100644
index 000000000000..1db9dd53fb39
--- /dev/null
+++ b/www/mod_pubcookie/pkg-plist
@@ -0,0 +1,8 @@
+pubcookie/config.sample
+pubcookie/keyclient
+@dirrmtry pubcookie/keys
+@dirrmtry pubcookie
+@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%%APACHEMODDIR%%/%%AP_MODULE%%
+%%APACHEMODDIR%%/%%AP_MODULE%%
+@exec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F
+@unexec echo "Don't forget to remove all ${MODULENAME}-related directives in your httpd.conf"