aboutsummaryrefslogtreecommitdiff
path: root/www/mod_python/Makefile
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-05-11 12:38:46 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-05-11 12:38:46 +0000
commit638e72dc16e7aabbe4e3b34e056c4bdd429e2774 (patch)
tree19706ca6c4c42cbe973f341e63c6084f4a768831 /www/mod_python/Makefile
parentfba7eacd8b6caab3554fcdd8f533a69aac0e71b8 (diff)
downloadports-638e72dc16e7aabbe4e3b34e056c4bdd429e2774.tar.gz
ports-638e72dc16e7aabbe4e3b34e056c4bdd429e2774.zip
Notes
Diffstat (limited to 'www/mod_python/Makefile')
-rw-r--r--www/mod_python/Makefile47
1 files changed, 14 insertions, 33 deletions
diff --git a/www/mod_python/Makefile b/www/mod_python/Makefile
index 1b3d91336e2e..4d5f3280ebe7 100644
--- a/www/mod_python/Makefile
+++ b/www/mod_python/Makefile
@@ -7,10 +7,10 @@
PORTNAME= mod_python
PORTVERSION= 2.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www python
-MASTER_SITES= http://www.modpython.org/dist/ \
- http://www.python.org/ftp/python/2.0/ \
+MASTER_SITES= http://www.python.org/ftp/python/${PYTHON_VERSION:S/python//g}/ \
+ http://www.modpython.org/dist/ \
http://www3.kr.freebsd.org/~perky/distfiles/
DISTFILES= mod_python-${PORTVERSION}.tgz ${PYTHON_DISTFILE}
DIST_SUBDIR= python
@@ -21,7 +21,6 @@ BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
USE_PYTHON= yes
-INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
@@ -29,53 +28,35 @@ PYTHON_WRKSRC= ${WRKSRC}/../Python-${PYTHON_VERSION:S/python//g}
APXS= ${PREFIX}/sbin/apxs
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --with-apxs=${LOCALBASE}/sbin/apxs \
- --with-python=${PYTHON_WRKSRC}
-CONFIGURE_ENV= PYTHON_BIN=${LOCALBASE}/bin/python
+CONFIGURE_ARGS+=--with-apxs=${APXS} --with-python=${PYTHON_WRKSRC}
+CONFIGURE_ENV= PYTHON_BIN=${PYTHON_CMD}
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S/^${LOCALBASE}\///g}
.if defined(WITH_OPENPTY)
OPTIONAL_LIBS+= -lutil
.endif
-.if defined(WITH_GNUREADLINE)
-OPTIONAL_LIBS+= -lreadline
-.endif
-
PYTHON_CONFIGURE_ARGS+= --without-threads
-PYTHON_SETUP_FILE?= ${PORTSDIR}/lang/python/files/Setup
-STRIP_BIN?= /usr/bin/strip
+STRIP_CMD?= strip
pre-fetch:
@${ECHO} ""
@${ECHO} "You may use the following build option:"
@${ECHO} ""
- @${ECHO} " PYTHON_SETUP_FILE=path specify python modules setup file"
+ @${ECHO} " WANT_EAPI=yes build as apache EAPI module (for apache13-modssl)"
@${ECHO} " WITH_OPENPTY=yes enables openpty function in posixmodule"
- @${ECHO} " WITH_GNUREADLINE=yes enables gnu readline library"
- @${ECHO} " DONT_STRIP=yes don't strip shared object"
@${ECHO} ""
pre-patch:
-.if !defined(${WITH_OPENPTY})
- ${PATCH} -s <files/optpatch-Python::configure
+.if !defined(WITH_OPENPTY)
+ ${PATCH} -s < ${PATCHDIR}/optpatch-WITHOUT_OPENPTY
+.endif
+.if defined(WANT_EAPI)
+ ${PATCH} -s < ${PATCHDIR}/optpatch-WANT_EAPI
.endif
pre-configure:
cd ${PYTHON_WRKSRC} && ./configure ${PYTHON_CONFIGURE_ARGS}
-.if !exists(${PYTHON_SETUP_FILE})
- @${ECHO} ""
- @${ECHO} "### COULD NOT FIND PYTHON SETUP FILE"
- @${ECHO} "### SPECIFY FILE PATH OR INSTALL PORT 'lang/python'"
- @${ECHO} ""
-.endif
-
-.if !defined(WITH_GNUREADLINE)
- ${SED} 's/^readline/#without_readline/g' ${PYTHON_SETUP_FILE} \
- > ${PYTHON_WRKSRC}/Modules/Setup
-.else
- ${CP} ${PYTHON_SETUP_FILE} ${PYTHON_WRKSRC}/Modules/Setup
-.endif
post-configure:
.if defined(OPTIONAL_LIBS)
@@ -88,8 +69,8 @@ pre-build:
cd ${PYTHON_WRKSRC} && ${MAKE}
post-build:
-.if !defined(DONT_STRIP) && exists(${STRIP_BIN})
- ${STRIP_BIN} ${WRKSRC}/src/mod_python.so
+.if !defined(DONT_STRIP) && exists(${STRIP_CMD})
+ ${STRIP_CMD} ${WRKSRC}/src/mod_python.so
.endif
post-install: