aboutsummaryrefslogtreecommitdiff
path: root/www/mod_python
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-11-15 14:09:37 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-11-15 14:09:37 +0000
commitc4c57226a78c9010b26ad28ec035d40b30279bbb (patch)
tree9396139aeb21eff7692cc8bebd5b9afce5600973 /www/mod_python
parentff2288619405323ddf0dbf8102088933221d9058 (diff)
downloadports-c4c57226a78c9010b26ad28ec035d40b30279bbb.tar.gz
ports-c4c57226a78c9010b26ad28ec035d40b30279bbb.zip
Notes
Diffstat (limited to 'www/mod_python')
-rw-r--r--www/mod_python/Makefile57
-rw-r--r--www/mod_python/distinfo4
-rw-r--r--www/mod_python/files/patch-Makefile.in18
-rw-r--r--www/mod_python/files/patch-configure11
-rw-r--r--www/mod_python/pkg-descr2
-rw-r--r--www/mod_python/pkg-message15
-rw-r--r--www/mod_python/pkg-plist24
7 files changed, 79 insertions, 52 deletions
diff --git a/www/mod_python/Makefile b/www/mod_python/Makefile
index 7473f5b19a6b..9d61b0362bf3 100644
--- a/www/mod_python/Makefile
+++ b/www/mod_python/Makefile
@@ -1,57 +1,40 @@
# New ports collection makefile for: mod_python
# Date created: 28 August 2000
-# Whom: Hye-Shik Chang <perky@freebsd-kr.org>
+# Whom: Hye-Shik Chang <perky@python.or.kr>
#
# $FreeBSD$
#
PORTNAME= mod_python
-PORTVERSION= 2.6
+PORTVERSION= 2.6.3
CATEGORIES= www python
-MASTER_SITES= ftp://freebsd-kr.org/pub/FreeBSD/ \
- http://www.modpython.org/dist/ \
- ftp://ftp.python.org/pub/python/src/ \
- ftp://ftp.cdrom.com/pub/python/www.python.org/ftp/python/src/ \
- http://sunsite.org.uk/Mirrors/ftp.python.org/pub/www.python.org/ftp/python/src/
+MASTER_SITES= http://www.modpython.org/dist/ \
+ http://www.pythonlabs.com/products/python2.0/downloads/
DISTFILES= mod_python-${PORTVERSION}.tgz ${PYTHON_DISTFILE}
+DIST_SUBDIR= python
-MAINTAINER= perky@freebsd-kr.org
+MAINTAINER= perky@python.or.kr
-BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13 \
- ${LOCALBASE}/bin/${PYTHON_VERSION}:${PORTSDIR}/lang/python15
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
RUN_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache13
-APXS= ${PREFIX}/sbin/apxs
-PYTHON_VERSION= python1.5
-PYTHON_NO_DEPENDS= yes
+PYTHON_WRKSRC= ${WRKSRC}/../Python-${PYTHON_VERSION:S/python//g}
+APXS= ${PREFIX}/sbin/apxs
-.if exists(${APXS})
-AP_LIBEXEC!= ${APXS} -q LIBEXEC
-.else
-AP_LIBEXEC= ${PREFIX}/libexec/apache
-.endif
+GNU_CONFIGURE= yes
+USE_PYTHON= yes
+CONFIGURE_ARGS= --with-apxs=${LOCALBASE}/sbin/apxs \
+ --with-python=${PYTHON_WRKSRC}
+CONFIGURE_ENV= PYTHON_BIN=${LOCALBASE}/bin/python
+PLIST_SUB+= PYTHON_LIBPATH=${PYTHON_LIBPATH:S/^${LOCALBASE}//g}lib
-COMPILEALL= ${PYTHON_LIBDIR}/compileall.py
+pre-configure:
+ cd ${PYTHON_WRKSRC} && ./configure --without-threads && cd Modules && ${MAKE} -f Makefile.pre Makefile
-PLIST_SUB+= AP_LIBEXEC=${AP_LIBEXEC:S/^${PREFIX}\///} \
- PYTHON_SITELIBDIR="${PYTHON_SITELIBDIR:S/^${PREFIX}\///}"
-
-do-build:
- @${ECHO} "=> Building lib${PYTHON_VERSION}.a for mod_python ..."
- cd ${PYTHON_WRKSRC} && ./configure && ${MAKE} lib${PYTHON_VERSION}.a
- @${ECHO} "=> Building mod_python.so ..."
- cd ${WRKSRC}/src;${APXS} -I../../Python-1.5.2/Include -I../../Python-1.5.2 -I${WRKSRC}/src/include -c mod_python.c -lm ../../Python-1.5.2/lib${PYTHON_VERSION}.a
- ${PYTHON_CMD} ${COMPILEALL} ${WRKSRC}/lib/python/mod_python
-
-do-install:
- cd ${WRKSRC}/src;${APXS} -i -a mod_python.so
- ${MKDIR} ${PYTHON_SITELIBDIR}/mod_python
- ${INSTALL_SCRIPT} ${WRKSRC}/lib/python/mod_python/* ${PYTHON_SITELIBDIR}/mod_python
+pre-build:
+ cd ${PYTHON_WRKSRC} && ${MAKE}
post-install:
- @${ECHO_MSG} "======================================================="
- @${ECHO_MSG} " mod_python was installed successfully."
- @${ECHO_MSG} " please read the manual at http://www.modpython.org"
- @${ECHO_MSG} "======================================================="
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/mod_python/distinfo b/www/mod_python/distinfo
index 28616745d17d..73735c8bea60 100644
--- a/www/mod_python/distinfo
+++ b/www/mod_python/distinfo
@@ -1,2 +1,2 @@
-MD5 (mod_python-2.6.tgz) = a71a014662a02648f4c2970814b296fd
-MD5 (py152.tgz) = e9d677ae6d5a3efc6937627ed8a3e752
+MD5 (python/mod_python-2.6.3.tgz) = c3c3a12a5fd6d86e9334cdf4f6a9e845
+MD5 (python/BeOpen-Python-2.0.tar.gz) = 8c4a64891d3dc6422df2514c603f0c98
diff --git a/www/mod_python/files/patch-Makefile.in b/www/mod_python/files/patch-Makefile.in
new file mode 100644
index 000000000000..de6da8520979
--- /dev/null
+++ b/www/mod_python/files/patch-Makefile.in
@@ -0,0 +1,18 @@
+--- Makefile.in.orig Wed Nov 15 05:33:51 2000
++++ Makefile.in Wed Nov 15 05:40:52 2000
+@@ -90,13 +90,10 @@
+ @echo
+ @echo "Performing DSO installation."
+ @echo
+- $(INSTALL) src/mod_python.so $(LIBEXECDIR)
++ /usr/local/sbin/apxs -i -a src/mod_python.so
+ @$(MAKE) install_py_lib
+ @echo
+- @echo "Now don't forget to edit your main config and add"
+- @echo " LoadModule python_module $(LIBEXECDIR)/mod_python.so"
+- @echo "and if your configuration uses ClearModuleList, then also"
+- @echo " AddModule mod_python.c"
++ @echo " ## Apache has to be restarted."
+ @echo
+
+
diff --git a/www/mod_python/files/patch-configure b/www/mod_python/files/patch-configure
new file mode 100644
index 000000000000..67f2ce25aee9
--- /dev/null
+++ b/www/mod_python/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig Wed Nov 15 05:33:42 2000
++++ configure Wed Nov 15 05:33:58 2000
+@@ -1312,7 +1312,7 @@
+ # check if python is compiled with threads
+ echo $ac_n "checking whether Python is compiled with thread support""... $ac_c" 1>&6
+ echo "configure:1315: checking whether Python is compiled with thread support" >&5
+-PyTHREADS=`$PYTHON_BIN -c "import sys; print \"thread\" in sys.builtin_module_names"`
++PyTHREADS="0"
+ if test "$PyTHREADS" = "1"; then
+ echo "$ac_t""yes" 1>&6
+ echo
diff --git a/www/mod_python/pkg-descr b/www/mod_python/pkg-descr
index 30d57845ab11..62e965e86fcc 100644
--- a/www/mod_python/pkg-descr
+++ b/www/mod_python/pkg-descr
@@ -6,4 +6,4 @@ WWW: http://www.modpython.org/
developed by Gregory Trubetskoy <grisha@ispol.com>
- Hye-Shik "Perky" Chang
-perky@freebsd-kr.org
+ perky@python.or.kr
diff --git a/www/mod_python/pkg-message b/www/mod_python/pkg-message
new file mode 100644
index 000000000000..64fe01bba1c4
--- /dev/null
+++ b/www/mod_python/pkg-message
@@ -0,0 +1,15 @@
+================================================================================
+
+Also remember to add to your Apache configuration in the appropriate context:
+
+PythonPath "['/path/to/foo', '/path/to/bar']"
+AddHandler python-program .py
+PythonHandler foobar
+PythonDebug On
+
+Where PythonPath includes the paths to at least the Python libdir, its
+site-packages dir, and to the dir where your Python programs are. Also consider
+including the dir to mod_python if your Python distribution is installed in a
+non-standard location. For more information, see http://www.modpython.org/.
+
+================================================================================
diff --git a/www/mod_python/pkg-plist b/www/mod_python/pkg-plist
index ae8efc48d8a3..d46dd4a28c4d 100644
--- a/www/mod_python/pkg-plist
+++ b/www/mod_python/pkg-plist
@@ -1,12 +1,12 @@
-%%AP_LIBEXEC%%/mod_python.so
-%%PYTHON_SITELIBDIR%%/mod_python/__init__.py
-%%PYTHON_SITELIBDIR%%/mod_python/__init__.pyc
-%%PYTHON_SITELIBDIR%%/mod_python/apache.py
-%%PYTHON_SITELIBDIR%%/mod_python/apache.pyc
-%%PYTHON_SITELIBDIR%%/mod_python/cgihandler.py
-%%PYTHON_SITELIBDIR%%/mod_python/cgihandler.pyc
-%%PYTHON_SITELIBDIR%%/mod_python/httpdapi.py
-%%PYTHON_SITELIBDIR%%/mod_python/httpdapi.pyc
-%%PYTHON_SITELIBDIR%%/mod_python/zhandler.py
-%%PYTHON_SITELIBDIR%%/mod_python/zhandler.pyc
-@dirrm %%PYTHON_SITELIBDIR%%/mod_python
+libexec/apache/mod_python.so
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/__init__.py
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/apache.py
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/cgihandler.py
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/httpdapi.py
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/zhandler.py
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/__init__.pyc
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/apache.pyc
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/cgihandler.pyc
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/httpdapi.pyc
+%%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python/zhandler.pyc
+@dirrm %%PYTHON_LIBPATH%%/%%PYTHON_VERSION%%/site-packages/mod_python