aboutsummaryrefslogtreecommitdiff
path: root/www/mod_ruby
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-15 16:09:52 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-15 16:09:52 +0000
commit5f39d369bcb965af07585bd5fe796ef03137f164 (patch)
tree926fd4b5a03f4b7cbaeeb97b776582d6d854ff3a /www/mod_ruby
parentbbf79edbdd20df6a942dfc018174d22f96015b8c (diff)
downloadports-5f39d369bcb965af07585bd5fe796ef03137f164.tar.gz
ports-5f39d369bcb965af07585bd5fe796ef03137f164.zip
Notes
Diffstat (limited to 'www/mod_ruby')
-rw-r--r--www/mod_ruby/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index 9d610c05eb96..e23e35ed0086 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -33,8 +33,15 @@ DOCS_EN= COPYING ChangeLog LEGAL LICENSE.apreq NOTICE \
README.en doc/default.css doc/*.en.*
DOCS_JA= README.ja doc/default.css doc/*.ja.*
+.include <bsd.port.pre.mk>
+
do-configure:
@cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${RUBY} ${RUBY_FLAGS} configure.rb ${CONFIGURE_ARGS}
+# dirty hack to force mod_ruby.so linked with lpthread.so, otherwise unresolved
+# symbols happen
+.if ${OSVERSION} >= 502102
+ @${REINPLACE_CMD} -e 's|-pthread|-pthread -lpthread|' ${WRKSRC}/Makefile
+.endif
post-install: doc-install
${INSTALL_DATA} ${WRKSRC}/examples/httpd.conf `${APXS} -q SYSCONFDIR`/httpd.conf.${PORTNAME}
@@ -44,8 +51,6 @@ post-install: doc-install
-e 's,%%SYSCONFDIR%%,'`${APXS} -q SYSCONFDIR | ${SED} 's:${LOCALBASE}/::'`',g;' \
${TMPPLIST}
-.include <bsd.port.mk>
-
doc-install:
.if !defined(NOPORTDOCS)
.if !defined(RUBY_NO_RD_HTML)
@@ -60,3 +65,5 @@ doc-install:
.endfor
.endif
@${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>